Skip to Content
avatar image
Former Member

Error while starting centeral instance

hi all

i'm facing a problem and i really need hellp, while trying to start SAP the central instance failed and this is the start log

Instance Service on host hostname started

Cannot create Lock File. ("sapstart.sem" Read-only file system)

(13906) Exiting with Return-Code -103. (Access permission denied)

Startup of Instance failed

i checked out the permission of this file and it's directory which was correct as follows:

drwxr-xr-x 2 bp1adm sapsys 12288 Sep 21 13:32 work <<<directory

the "work" directory contains the file which the error logs stated ,when i try to create a file under the "work" directory it says :

touch: cannot touch `new_file': Read-only file system

i unmounted and re-mounted again and tried to create a file and i succeeded ; tried to start SAP again but it failed giving same error again and i failed to write under the "work" directory again

Database is up and running

NETWEAVER 7 EHP 1

DB6

thanks

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 21, 2010 at 12:50 PM

    Hi,

    Check whether file system is created with read and write permission.

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 21, 2010 at 03:00 PM

    Hello,

    Ensure that all of the systems processes have stopped.

    If necessary, run the files kill.sap and shutdown.sap in the SAP System

    Working-Directory.

    ( /usr/sap/<system-name>/<unit name>/work ).

    Ensure that all IPC objects (shared mem, semaphores, ...) have been

    deleted. ( showipc <system-no) bzw. cleanipc <system-no> )

    What OS version do you have is it Linux?

    regards,

    John Feely

    Add comment
    10|10000 characters needed characters exceeded