Skip to Content
avatar image
Former Member

Cube to Cube (via Transformation) incomplete data

Dear all,

I am trying to write data from one cube to another cube via DTP (FULL). I didn't set any Filters but the DTP doesn't deliver any data before Fiscal Period 005.2008. When I create a query on the first (SOURCE Cube) Cube I am able to see data from 2006 to 2010 but when I look at the data in the Back end (Right click on Cube - Display Data) I am not able to see any data before 005.2008.

When looking at the requests I recognized that the data was compressed until the 16th of May 2008. Therefore I compressed the data until July 2008 to check whether the compression could be the reason for the missing data. Nevertheless I am still not able to see any data before 005.2008 no matter if I compress more data or not.

Do you have any ideas why I can see the data in the query but not in the cube?

Best regards

Stefan

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

12 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 20, 2010 at 06:37 PM

    Try to set filter when you load to Target cube and check whether you get data or not? Or Pick a Document number which is not compressed in a request & load that.Do you see data in E Table at all?

    @AK

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 21, 2010 at 08:32 AM

    Hello Stefan,

    what have you done after compressing data till july 2008? Load again in the target cube or just check data? It could be that there is a different use of the factview on using a query than on using transformation or update rules. What is your BW release?

    Have you checked which data you can see by using the factview. Normally convention is /BIC/V<ICUBE>F.

    Maybe note https://websmp130.sap-ag.de/sap%28bD1kZSZjPTAwMQ==%29/bc/bsp/spn/sapnotes/index2.htm?numm=561961

    helps. But as far as I see it is just for pre 7.x releases.

    Best regards,

    Peter

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 01:03 PM

    It's silly , but make sure you have given right selections for the right time(ex.001.2008 to 005.2008) char to display data for source cube.

    Cube to cube - check the transformations if it has any start routine which deletes data before 005.2008

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 20, 2010 at 01:05 PM

    maybe the query is based on a multicube...and the data prior to 005.2008 is perhaps stored in another cube than the one you're looking at...

    M.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 01:06 PM

    Hello Srinivas,

    I checked all selections but even when I do not make any selection at all and want to see all data (~1.000.000 data records) the data starts with Fiscper 005.2008

    There must be something else I don't see.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 01:09 PM

    Hello M.

    I thought about this as well, but I built the query on the cube itself.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 02:20 PM

    Dear all,

    when I look at the E table, I can see the data, but when I try to extract all data there is no data before the mentioned FiscPer

    regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 03:07 PM

    hi Stefan,

    have you checked the aggregates built on the cube. it may happen that the data is there in the aggregates and then the cube is compressed. Hence you are not getting the data in the cube but the query is picking them up from the aggregates.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 03:36 PM

    If data is present in the query, it must be present in the cube when displaying its content. Silly question but did you check the number of rows you are displaying in your cube? Default value is 200, try putting a huge number.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 21, 2010 at 07:01 AM

    Thank you all for your help.

    There are 100000 records in the cube and I adjusted the output to 1.000.000 records.

    In addition I am able to see all records in the E table.

    Dear Amit,

    could you please advice how I am able to check the aggregates and what to do once I checked the aggregates.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded