Skip to Content
avatar image
Former Member

OSCOL not functioning properly

Dear All,

In my SAP system which is Ecc6.0 OSCOL is started but cant find the operating system data, when i go to check the file system,cpu utilization or Memory allocation i cant see anything in ST06. When checked with Opearting system collector its started and on from last 20 days.

Please suggest

Thanks in Advance

Rajesh Phutane

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

6 Answers

  • Best Answer
    Sep 20, 2010 at 08:40 AM

    You can stop and restart the collector

    saposcol -k to stop and saposcol -l to start.

    Also check the collector log dev_coll

    Regards

    Juan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 09:08 AM

    Hi Jaun

    i have started and stoped the sap OSCOL, even i checked with dev_coll file in operating system directory. I cant find any errors in that file

    when i checked in operating system collecotr details its saying last write and read access with todays date and time but i cant see all the information such as cpu, file system except pool in ST06.

    Please suggest.

    Rajesh Phutane

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 11:47 PM

    Hi Rajesh,

    Please check Note 688131 - Windows: missing data in ST06/OS06, if it will help you.

    Regards,

    Sanujit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 09:17 AM

    Hi jaun

    It's Running. From were i can check the saposcol (at kernel) has authorizations 4775

    Rajesh Phutane

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 09:31 AM

    Hi Jaun.

    i have checked the permission in windows 2003 server edition operating system under kernel directory its showing full permission.

    I dont think there some problem on this area, iam getting partial data for example Pool details but not getting Filesystem and cpu utilization.

    What may be reason.

    Rajesh Phutane

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 20, 2010 at 02:32 PM

    Hi,

    Make sure that the job SAP_COLLECTOR_FOR_PERFMONITOR runs in the client 000. The data will not be available in ST06 if this jobs runs in a client different than 000. Also check the system time zone and if needed make the necessary changes in the tcode STZAC.

    Hope this will resolve ur issue.

    Regards,

    Varadharajan M

    Add comment
    10|10000 characters needed characters exceeded