Skip to Content
avatar image
Former Member

Asset depreciation calculation

Hi,

Created on Asset in 2010 and its Dep. start date is 03/16/2010, Useful life 10 yrs and dep. rates are as follows

1st yr --> 3.0000, 2nd yrs --> 12.0000, 3rd yr --> 12.0000, 4th yr --> 11.0000, 5th yr --> 10.0000, 6th yr --> 10.0000, 7th yr --> 9.0000, 8th yr --> 9.0000, 9th yr --> 9.0000, 10th yr --> 8.0000 & 11th yr --> 7.0000.

Dep. key is set up with 11yrs of dep. rates though it has 10 yrs of useful life. As per the dep. key, the asset has to be completely depreciated by Feb 2021.

Issue: System depreciated the Asset in 2010, for 9 periods correctly with 1st yr rate.

In 2011, 2 periods with 1st yr rate + 10 prd with 2nd yr rate correctly.

In 2012, 2 prds with 2nd yr rate + 10 prds with 3rd yr rate correctly.

In 2013, 3 prds with 3rd yr rate + 9 prds with 4th yr rate

 Why system considered 3 periods with 3rd yr rate and 9 periods with 4th yr rate in 2013? System suppose to consider 2 periods with 3rd yr rate and 10 prds with 4th yr rate, but its not happened. Why?

Similarly In 2014, system considered 3 periods with 4th yr rate + 9 prds with 5th yr rate.

Upto 2016 it has considered the 3 prds with old rate + 9 prds with new rate.

Again in 2017 & 2018, system considered 2 prds with old rate + 10 prds with new rate.

Once again 2019 & 2020 system has considered 3 prds with old rate + 9 prds with new rates.

I would like to know why the system has taken different calculation procedure in different years. What could be the reason?

Regards

Murali

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 16, 2010 at 07:16 PM

    Hi,

    What is the depreciation key you have maintained in the asset master ? Check multilevel method settings.

    Best Regards,

    Madhu

    Add comment
    10|10000 characters needed characters exceeded