Skip to Content
avatar image
Former Member

How to use ODS As-Built Summary Report

Hi,

I am trying to use ODS As-Built Summary Report.

Then, first of all, it tries to configure Audit Log.

2.1.1 of ODSRG_SAPME_52_FINAL.pdf In Configuring the Audit Log, there is the following descriptions.

You can configure an objectu2019s audit log by selecting one of the following in the EJBDefBundle.properties file:

However, I cannot find EJBDefBundle.properties file.

Please teach if you know the preservation place of EJBDefBundle.properties file.

Am I misunderstanding the preparation to use ODS As-Built Summary Report?

Please teach a correct way if it is so.

thanks

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Sep 15, 2010 at 12:40 PM

    As to ODS As-built Summary report, you need to execute ODSGenealogyETL.bat in ME Clients to place assembly data from WIP to ODS.

    In case you do not use Time-based Component Traceability, you can update ODSGenealogyETL.bat to leave only ODSSFCBOMExtract and ODSSFCBOMExpansion transactions for execution.

    Regards,

    Sergiy

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 16, 2010 at 11:57 AM

    Hi Ivan and Sergiy,

    I confirmed SS100 activity according to your proposal.

    Then, the checkbox of Visible in Activity Manager was unchecked, so I checked it.

    System Setup Maintenance appeared under Maintenance->System Configuration by doing so.

    However, an internal error occurred when SFC was browsed at ODS As-built Summary report.

    It tries to investigate the log.

    Moreover, the whereabouts is being confirmed for ODSGenealogyETL.bat.

    It has progressed considerably thanks to your advice though the problem is not solved still.

    I wish to express my gratitude.

    Thanks

    Yousuke

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Sergiy Katerinich

      Hi Sergiy,

      I was able to find ODSGenealogyETL.bat thanks to your advice.

      However, some errors occur if ODSGenealogyETL.bat is executed.

      Because these problems contributed another thread ([ODSGenealogyETL.bat's problem|ODSGenealogyETL.bat's problem;),

      this thread is assumed to be completion.

      Thanks

      Yousuke

  • avatar image
    Former Member
    Sep 14, 2010 at 09:47 PM

    Hi Yousuke

    Looks like the document is a little bit outdated.

    Audit Log is configured in System Setup activity under Maintenance->System Configuration. There is an Audit Log tab where you can set values Off, All or Current for various object.

    Fo more details refer to the [Changing System Setup Settings|http://help.sap.com/saphelp_me52/helpdata/en/56/bf997e76dd42afa29d24d92c2d6853/frameset.htm] page in SAP Online Help for ME

    Hope it helps

    Ivan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 15, 2010 at 07:47 AM

    Hi Ivan,

    thanks for your fast reply,

    I tried to execute the method that had been taught by you.

    However, I was not able to find System Setup activity.

    I was not able to find activity with Audit Log tab though I confirmed all items under Maintenance->System Configuration.

    I will confirm SAP Online Help for ME a little more.

    best regards,

    Yousuke

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Sergiy Katerinich

      Hi Yousuke,

      Check the steps that Sergiy recommended.

      Also I would suggest to check Activity Maintenance. Retrieve activity SS100, which is System Setup and make sure both checkboxes Enabled and Visible in Activity Manager are checked. Save activity even if you haven't changed anything. Logout and login again. Check if System Setup appeared under Maintenance->System Configuration

      Thanks

      Ivan