Skip to Content
avatar image
Former Member

Block port on Value Exception

Hi,

Whenever there is a Value or Import exception,port is not blocked but now customer wants to block the port in case of Value Exception as there can be scenario where a record is updated in the source system but due to some issue it failed under value exception. A different user updates the same record in source system and it pass through MDM correctly. Now some one will check the value exception and process the record manually which will overwrite the changes .

Kindly suggest if there is some method to block port in case of value and import exception.

Thanks and Regards,

Neethu Joy

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Sep 14, 2010 at 06:36 AM

    Hi Neethu,

    The port will be blocked ONLY in case of Structural Exceptions.

    Even if you set the import for Fail, i believe you can see the status as "Has Exceptions" , but the port will not be blocked.

    As a work around, you can use PI for monitoring and check the file which could not be imported.

    Thanks,

    Priti

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 14, 2010 at 07:21 AM

    Hi Neethu

    As rightly explained blocking the port for Value and Import exceptions is not possible.

    Now coming to the initial requirement- *there can be scenario where a record is updated in the source system but due to some issue it failed under value exception. A different user updates the same record in source system and it pass through MDM correctly. Now some one will check the value exception and process the record manually which will overwrite the changes .

    Why should this happen- For the lookup values how are you refreshing MDM from the source system? If this is not automated the above makes a scenario for automatically refreshing the lookup values from the source system to MDM.

    Also if the User1 is wrongly editing a record in source system MDM by design is not allowing to import that record. User2 edits(corrects) the record in source system again which is reflected in MDM correctly. Here if the client needs to see the changes made at record level (by user1/all incorrect updates) then the change tracking or logs should be seen/developed in the source system itself- since MDM has been designed to filter correct records flow only.

    Hope this helps-Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 13, 2010 at 10:27 AM

    Hi Neethu,

    Kindly Follow the step :

    1. select Inbound port in MDM console and set Block on strctural exceptions = "Yes"

    2. change in import map i.e Import manager configuration setting Under Default MDIS Handling -


    >

    Upmapped Value Handling = Ignore\Add\*Fail* Set to Fail

    Hope Above mention point will resolved the problem if not revert back

    Thanks,

    Jignesh Patel

    Edited by: jignesh patel on Sep 13, 2010 3:58 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 13, 2010 at 10:55 AM

    Hi ,

    As fas as i am concerned this is not possible.You can put constraint on structural exception only.

    Thanks,

    Sudhanshu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Neethu,

      As per my understanding, value exceptions come only if you don't have that value already existing in MDM. So in this case try setting Property Upmapped Value Handling = Fail in configuration options of MDM Import Manager and save this in your Map.

      So whenever a new value which does not exist in MDM comes, this file record will fail and thus you can have file available(block) in value exception folder of your repository port.

      Just check and revert with result.

      Regards,

      Mandeep Saini

  • avatar image
    Former Member
    Jan 13, 2012 at 10:02 AM

    Thanks for the help but i wanted a workaround and has found one.

    Add comment
    10|10000 characters needed characters exceeded