Skip to Content
avatar image
Former Member

German language issue

Hello Experts,

System details -

SRM 5

R/3 4.6c

Classic scenario

We have enabled German Logon language. When the user creates a SC after having logged in the German language on the web browser the screens etc are translated in German language. We have also maintained the translations of the custom error message in German languages and hence the display is in the correct language ie German.

However for a few of the standard R/3 error messages we are not getting the translation in German.

eg Message Class KI, Message 235

"Account & requires an assignment to a CO object"

Even though the user is logged in German language, this error message is displayed in English.

When we check in R/3 the translation has been maintained - however in SRM the German translation does not get displayed.

Please let me know in case there is any R/3 or SRM configuration to be done.

Regards,

Amish

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Sep 09, 2010 at 03:14 PM

    Just a thought: could the user's default language be English (SU01)?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      Make sure User's language is DE in his settings.

      Secondly, login to SRM via GUI and see whether the above message number has got its description maintained in German or not. if not maintain the translation or send a note to SAP they will fix it via an OSS note.

      One more reason could be "As the account assignment is checked via an RFC Call to ECC, check what is the language of RFC user while the call is made to ECC for account assignment check"

      Regards

      Virender Singh