Skip to Content
author's profile photo Former Member
Former Member

Error while deploying in Visual Admin

Hi,

Currently I'm having an error while I do my application deployment via Visual Admin. I realized afterI login to Visual Admin then I press Services>Deploy, it will printed a stack of error of java.lang.NullPointerException. I screenshot for better reference.

[Click Here|http://img687.imageshack.us/img687/3205/errorq.gif]

It showed error on com.sap.engine.services.rmi_p4/MarshalInputStream.setProfile. Any cause of this or solution as now I can't deploy my application.

Thanks.

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2010 at 01:38 PM

    Hello Adrian,

    The fix is in versions later that 7.0 SP15. To solve the error you have to upgrade the J2EE engine to a version higher than SP15. I also found note 1325234 that deals with this exact error, so if you cannot now upgrade to a version higher that SP15 you can apply the fix the note contains.

    I hope this helps you.

    Regards,

    Blanca

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Blanca,

      I just checked the server and the version is SP13. But before I request for an upgrade I need to justify also.

      I checked out the note 1325234 and follow what it asked. Is correct as I unable to see any entries after I clicked All Application. But in my defaultTrace log didn't print out the error message.

      I only will see the message when I go to Visual Admin>Server>Services>Deploy and it will print as I showed in the screenshot. Just want to double confirm for the error.

      Thanks.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2010 at 07:25 AM

    Have you tried deploying your software using SDM instead of VA?

    Kind regards,

    Mark

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2010 at 01:15 PM

    Hello Adrian,

    What is the java system version you are using? The problem you are facing with the deploy service (NullPointerException) is a known one and it is fixed in the later releases.

    Regards,

    Blanca

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 08, 2010 at 07:32 AM

    Hello Adrian,

    Yes, the error is the same although it cannot be seen in the server defaulttrace. In SP 13 version the issue in the code of the P4 J2EE service is there so the solution is to upgrade to a version where this is corrected. So, the upgrade is justified.

    I hope this answer also helps you.

    Regards,

    Blanca

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 08, 2010 at 07:39 AM

    You are welcome 😊

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.