Skip to Content
Sep 03, 2010 at 06:36 AM

Oracle Upgrade : -> 11.2 dbua hangs



I have started the dbua once and it has retrieved the database information. After this i pressed cancel to verify some of the warnings. When I tried to start it again, it hangs in the "getting database information..please wait" popup.

I found that I can try to remove the ../cfgtoollogs/dbua/<sid>/upgrade* directory which I have done.

I have also tried to start up the database in UPGRADE mode since I found this to be a possible cause as well.

Still, I cannot get passed the "getting database information" popup.

I can see that the "upgrade<n>" directory is not recreated, and the trace.log file from dbua stops processing immediatley after start and I can also see this error in the log, but I'm not sure if it's related to my problems or how to resolve it:

[main] [ 2010-09-02 13:00:52.811 CEST ] [HAUtils.getCRSHome:545]  Getting configured CRS/HAS home for Oracle home ( /oracle/AC1/112_64 ) ...
[main] [ 2010-09-02 13:00:52.812 CEST ] [GETCRSHOMEUtil.<init>:76]  Toolname: getcrshome   ---    Tool location: /oracle/AC1/112_64/srvm/adm
inTool dependencies: [Ljava.lang.String;@73ca73ca
[main] [ 2010-09-02 13:00:52.813 CEST ] [NativeSystem.isCmdScv:472]  isCmdScv: cmd=[]
[Thread-5] [ 2010-09-02 13:00:52.875 CEST ] []  In
[Thread-6] [ 2010-09-02 13:00:52.875 CEST ] []  In
[main] [ 2010-09-02 13:00:52.968 CEST ] [CmdToolUtil.doexecute:372]  nativeSystem.runRemoteExecCmd failed. Command = /oracle/AC1/112_64/srvm
/admin/getcrshome arguments = [] env = null
[main] [ 2010-09-02 13:00:52.971 CEST ] [HAUtils.isHASConfigured:354]  Ignoring exception in isHASConfigured: PRCT-1011 : Failed to run "get
PRCT-1011 : Failed to run "getcrshome"
        at oracle.cluster.deployment.ClusterwareInfo.getConfiguredCRSHome(
        at oracle.sysman.assistants.util.hasi.HAUtils.getCRSHome(
        at oracle.sysman.assistants.util.hasi.HAUtils.getHASHome(
        at oracle.sysman.assistants.util.hasi.HAUtils.isHASConfigured(
        at oracle.sysman.assistants.dbma.Dbma.execute(
        at oracle.sysman.assistants.dbma.Dbma.statusMain(
        at oracle.sysman.assistants.dbma.Dbma.main(
Caused by: PRCT-1011 : Failed to run "getcrshome"
        at oracle.cluster.cmdtools.CmdToolUtil.doexecute(
        at oracle.cluster.cmdtools.CmdToolUtil.execute(
        at oracle.cluster.cmdtools.GETCRSHOMEUtil.getCRS_HOME(
        at oracle.cluster.cmdtools.GETCRSHOMEUtil.getCRS_HOME(
        at oracle.cluster.deployment.ClusterwareInfo.getConfiguredCRSHome(
        ... 6 more

My feeling is that something still needs to be cleaned up or added for the dbua to continue but I cannot find what.

The dbhost is on AIX.

Best Regards