Skip to Content
author's profile photo Former Member
Former Member

Add MATNR to 0FI_GL_4

Hi Experts,

We are trying to modify the 0FI_GL_4 extractor to pull in Material Number information.

We understand that in this case MATNR field should be appended through CI_BSIS after reading some of the posts.

We tried following approach,

1. Create CI_BSIS

2. Add 'MATNR' same as BSEG-MATNR

3. Activate CI_BSIS

4. Activate DTFIGL_4

5. Activate Datasource through RSA6

However when we execute RSA3, MATNR is not populated.(we have checked BSEG and there are values against MATNR)

Request your guidance for any missing steps in this case.

Thanks,

Gaurav

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 01, 2010 at 04:32 PM

    Hi,

    Debug the extractor in RSA3 and see why the data is not populated.

    Regards,

    Raghavendra.

    Add a comment
    10|10000 characters needed characters exceeded

    • 1. The name for the fields in CI_BSIK needs to be exactly the same as in BSEG, i.e MATNR needs to be named MATNR not ZZMATNR as normal practice would require, because in the extractor evalutes field names for selection.

      2. You need to un-check the flags for 'Hidden' AND the flag for 'Known in own exit' in for the new MATNR field in the datasource 0FI_GL_4 (RSA6).

      That should do it

      Regards,

      Ola

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.