Skip to Content

No 'packet size' option for rs_subcmp?

Looking at the documentation, it looks like there's no packet size option for rs_subcmp.

On my version 16 ASE server, when rs_subcmp runs a command, the corresponding ASE process shows the network_pktsz value (in sysprocesses) having the same value as the server "default network packet size" (2k in my case)

Even if the select statement returns rows much smaller than the packet size, if it's a streaming select, won't the ASE server batch the return rows up to fill up the network packets?

If so, then it would seem like rs_subcmp really should have a network packet size option (like isql's -A option).

Thanks in advance
Ben

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Feb 28, 2019 at 03:55 PM

    Hi Ben,

    Thank you for your suggestion on improving rs_subcmp. That functionality in the Replication Server is very old and inefficient. The engineers decided to re-write that functionality. The new product with that functionality is called Data Assurance. I would look at Data Assurance since it is much more robust and can compare large amounts of data in a more efficient manner.

    Regards,

    Dale Newth

    Add a comment
    10|10000 characters needed characters exceeded

    • But according to "Replication Server Data Assurance Option Installation Guide", the new Data Assurance product requires a "REP_DATA_ASSURANCE" license, so it's not an option for me.

      Re: That functionality (rs_subcmp) in the Replication Server is very old and inefficient

      Well, it's actually pretty fast and does a reasonable job of retrying transient failures. But I hear what you're saying about it getting only minimal support now. Too bad.

      For anybody else reading this, be careful using the rs_subcmp -h "fast comparison" option (aka hash row values then compare only the hashes). If if you use the default hash method on large varbinary fields, it kills the procedure cache. This is in CR 811073: Very large procedure cache increase if using hash() on large varbinary() field. But that CR is not listed in the KBA.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.