Skip to Content
avatar image
Former Member

PCO 2.1 installation

I am installing PCO 2.1 on my personal laptop to test out its capabilities and when I go to set up a new source system (OPC Server), I enter the server name or its IP address and it comes back with no OPC servers found. If the UDS is up and running on the machine I am trying to connect and I know an OPCserver has been installed and turned on, why doesn't PCO see it on its list? Is there something I am missing from the installation?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 29, 2010 at 03:18 PM

    Chip,

    In order for PCo (or any other OPC Client) to browse for OPC servers that are on a network, you MUST configure Microsoft DCOM (Distributed COM) on both the client and the server for OPC connectivity to work. Here is a link to an OPCFoundation document that describes this process:

    http://www.opcfoundation.org/DownloadFile.aspx?CM=3&RI=326&CN=KEY&CI=282&CU=19

    It is for XP SP2 but is applicable to Vista, Win2K3 and probably Win7 and Win2k8.

    It is strongly recommended that you install PCo on the OPC Server box to eliminate the DCOM setup requiremenst. If this is not practical, you (and your Network Administrator) will need to configure DCOM.

    Another option is to use the OPC-UA source agent in PCo if your OPC Server currently supportes it. However, this is a fairly new technology and may require some effort to get everything configured.

    - Steve

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 27, 2010 at 03:42 PM

    Hi Gregory,

    You can install Matrikon OPC Server on your laptop it is a free software and start same.

    Then test for localhost in PCo source it should show you some OPC Server.

    Hope This Help!!

    Regards,

    Manoj Bilthare

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      thanks but this defeats the purpose. I am not trying to test it with a simulator, I am trying to test it with a current SCADA system that has an OPC server installed. PCO is not seeing the OPC Server and I am trying to figure out why. Any suggestions?