Skip to Content

SDK Assistant crashes upon opening

Hi,

I have downloaded the latest SDK Assistant (3.0 SP1) but upon opening the app, it crashes immediately.

The error report lists:

Crashed Thread:        18  Dispatch queue: com.apple.root.default-qos Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY
Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [51176]

Stacktrace for thread 18:

Thread 18 Crashed:: Dispatch queue: com.apple.root.default-qos
0   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b09dc4 specialized PersistedAssistantProjectLoader2_1.loadProject(from:xcodeProjectPath:) + 7140
1   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b0a107 specialized PersistedAssistantProjectLoader2_1.loadProject(from:) + 823
2   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b07d39 protocol witness for PersistedAssistantProjectLoader.loadProject(from:) in conformance PersistedAssistantProjectLoader2_1 + 9
3   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b0e4ff AssistantProjectManager.loadFromContextJSON(at:) + 399
4   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b0e5bd closure #1 in AssistantProjectManager.loadProject(from:_:) + 45
5   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b12969 partial apply for closure #1 in AssistantProjectManager.loadProject(from:_:) + 25
6   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b12820 partial apply for closure #1 in AssistantProjectManager.loadProject(from:_:) + 16
7   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b14a49 closure #1 in AssistantProjectManager.loadProject(from:_:)partial apply + 9
8   com.sap.HCPSDKforiOSAssistant.Assistant0x0000000106b013d0 thunk for @escaping @callee_guaranteed () -> () + 32
9   libdispatch.dylib             0x00007fff712c7d53 _dispatch_call_block_and_release + 12
10  libdispatch.dylib             0x00007fff712c8dcf _dispatch_client_callout + 8
11  libdispatch.dylib             0x00007fff712cb240 _dispatch_queue_override_invoke + 767
12  libdispatch.dylib             0x00007fff712d6d26 _dispatch_root_queue_drain + 325
13  libdispatch.dylib             0x00007fff712d74bd _dispatch_worker_thread2 + 90
14  libsystem_pthread.dylib       0x00007fff715096dd _pthread_wqthread + 619
15  libsystem_pthread.dylib       0x00007fff71509405 start_wqthread + 13

In the Console app, I see the following error logged error:

Unable to load Info.plist exceptions (eGPUOverrides)

Anyone have an idea what could go wrong here? I have tried with 3.0 PL05, but that is having the same issue, so I suspect it has something to do with my local development machine. I do have Xcode 10.1 running.

Thanks in advance!

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Feb 25, 2019 at 11:21 AM

    Hi Robin,

    During the startup, the Assistant tries to load your old generated project. It seems that something went wrong here. We recently did some fix here, which could fix your issue in the next patch. But to be sure: Could you please export your configurations and send us?

    To export your userDefaults, please use the following command from Terminal:
    defaults export com.sap.SAPCPSDKforiOSAssistant <path to a plist file where you want to save to>

    If you want to start the Assistant like a fresh install just clean your UserDefaults from terminal:

    defaults delete com.sap.SAPCPSDKforiOSAssistant

    Thanks and Best regards,

    David

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi David,

      Many thanks for your swift — pun intended — reply! :-)

      Removing the Assistant's defaults indeed did the trick, the SDK Assistant now opens successfully!

      It appears the really old ones were wrecking havoc; I tried importing an old one and it failed with the following errors:

      Loading project from path 'file:///Users/robin/Development/Sandbox/TEMP/MyDeliveries/MyDeliveries.xcodeproj' failed. - Error Log: The operation couldn’t be completed. (Assistant.PersistedAssistantProjectLoaderError error 1.) (File: AssistantProjectManager.swift, Function: loadProject(from:_:), Line: 66)
      
      Failed to import project. - Error Log: The operation couldn’t be completed. (Assistant.PersistedAssistantProjectLoaderError error 1.) (File: NavigationController.swift, Function: importProject(from:), Line: 177)
      

      Again, many thanks for your help, much appreciated!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.