Skip to Content
avatar image
Former Member

Dropped connection issue

We are having a issue where users in our ECC6.0 and BW NW2004s systems are having thier connections dropped. These systems are located at a remote location.

I understand this issue has many facets and I am trying to ensure we check all of them to discover the REAL problem.

The errors from sm21 are similar to this:

Date : 08-23-2010															
															
	Time	SAP instance			Type	Nr	Clt	User	TCode		Terminal	Priority	Grp	N	Text
															
	12:59:08	sapsbpa3_SBP_23			DP								Q0	I	Operating system call recv failed (error no. 10053)
	12:59:08	sapsbpa3_SBP_23			DP								Q0	4	Connection to user 5673 (DUCLOSD ), terminal 127 (AL30023305NP) lost

This is only one there are hundreds of these in SM21

Typical log entry for the dispatcher will be included in a subsequent post because the message formatting is destroyed when included here.

1. Network is not intermittent or transient.

a. Not all users are affected on a server just some and they are from various sites around a fairly large region.

b. They can immediately reconnect without issue.

2. Firewalls do not show dropped connections.

3. Patches for the OS were put in place AFTER the issue started.

The systems are running on Windows Server 2008.

The event logs for the servers show the same information as SM21.

Client event logs Windows XP show no errors

4. TAXBSI and related components were recently updated to cyclic o and tub 183

a. Implemented prior to the issue and the issue did not start immediately after the implementation and doesn't occur on other system that were upgraded (DEV, QAS)

The SAPGUI is at the recommended level for the upgraded components and Several of the users who have experienced this connection issue have updated their GUI to the latest and greatest (19) and still are experiencing the issue.

The issue does not occur at any specific time(although many occur when the system polls idle connections at the rdisp/keepalive interval) they do not happen to users at a specific location. Not all users on a particular application server are affected only some of them. The only real connection is that they are idle for some length of time.

I have experienced the disconnection personally but, I cannot replicate the problem.

I have checked my DEV and QAS systems and they do not have this issue, however; they have fewer users and lower utilization. Our production BW at the remote location does have similar usage as DEV and QAS and does have the connection issue

I apologize for the message being smashed together formatting is to blame

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Aug 25, 2010 at 07:50 PM

    the Dispatcher log entry (one of many)

    Mon Aug 23 12:59:08 2010
    ***LOG Q0I=> NiIRead: recv (10053: WSAECONNABORTED: Software caused connection abort) [nixxi.cpp 4436]
    *** ERROR => NiIRead: SiRecv failed for hdl 85 / sock 1804
        (SI_ECONN_BROKEN/10053; I4; ST; 169.157.6.121:2429) [nixxi.cpp    4436]
    Network error of client T127, NiBufReceive (-6: NIECONN_BROKEN), dp_tm_status=3
    Client address of T127 is 169.157.6.121(al30023305np.dcps.duval.us)
    ***LOG Q04=> DpRTmPrep, NiBufReceive (5673 DUCLOSD 127 AL30023305NP) [dpxxdisp.c   12260]
    RM-T127, U5673, 220      DUCLOSD, AL30023305NP, 12:38:08, M1, W1, PPOS, 3/1

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 26, 2010 at 08:13 AM

    Hi,

    The entries in the SAP system log (SM21) says that the connection is lost abruptly instead of proper log off. It is just an information that the connection is lost/disconnected.

    Connection to user 5673 (DUCLOSD ), terminal 127 (AL30023305NP) lost

    Usually happens if the connection fails while the user is connected to the SAP DB.

    The possible reasons are:

    1. The network drops (In ur case, it seems that the network connectivity is good)

    The only real connection is that they are idle for some length of time.

    2. The other possible reason is the setting/configuration at the gateway/firewall that disconnects the sessions which were left idle for a period of time. You can check this by logging into SAP in the server console itself (avoiding the gateway interference). I've had the same issue and this check helped me to sort out the issue.

    Hope this will definitely sort ur issue out.

    @Were u able to sort out ur issue ? Ifso, mark this thread as answered to aid others with same issue.

    Regards,

    Varadharajan M

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 26, 2011 at 05:50 PM

    We are now facing the same problems with random users at different time on different days get disconnected from SAP. Right after, they can log back in.

    In SM21, it point to it as a network error. But I want to make sure that all SAP settings are correct. Network team is quetioning that since many of the other servers are also hosted at the same remote location and none of these application have any issue, then does only SAP users have disconnects.

    Can someone please give me some tips on what could be the cause for this issue.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      We are having exactly the same issue, can you please let us know what was the fix done for solving your issue?

      Regards,

      Manish

  • avatar image
    Former Member
    Jan 10, 2014 at 02:09 PM

    Hi

    Please take a look at this solution:

    A case at Microsoft then revealed hotfix KB2524478 which solved this issue once and for all.

    http://texhex.blogspot.de/2012/03/sapgui-crashes-with-wsaeconnaborted.html

    Kind regrads

    Ina

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 25, 2014 at 01:55 PM

    Dear All

    We have been facing the same peculiar issue in our landscape.

    Request to please suggest , in case anyone has managed to resolve it.

    Regards

    Urvish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 05, 2016 at 04:34 PM

    Hi,

    we are facing the same issue, could anyone please suggest the solution?

    i tried to implement the microsoft hotfix but is not applicable to our system

    Thanks,

    Rajesh K Sahu

    Add comment
    10|10000 characters needed characters exceeded