Skip to Content
0
Former Member
Aug 25, 2010 at 01:54 AM

2EETW169 no connect possible: "DBMS = ORACLE

149 Views

Dear Experties,

I need your help to our problem. in 7 August 2010, our SAP Production will doing Backup offline, so the application will shutdown.

Because our system use Clustering, so we shutdown our SAP using clustering.

We check the clustering and there some service is hang, so admin kill the process.

When we want to start up the SAP, the clustering is not want to up. so admin use manual script to run cluster.

The SAP in TENR3P01 is up, but in TENR3P02 is not.When I start manually in TENR3P02, is still cannot up. The massage is "ABAP Database is not available via R3trans".

This is log in trans.log in TENR3P02.

_________________________________________________________________________________

4 ETW000 /usr/sap/RP1/SYS/exe/run/R3trans version 6.13 (release 640 - 07.01.08 - 14:25:00).

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 21.08.2010 - 05:32:28

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: /usr/sap/RP1/SYS/exe/run/R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Sat Aug 21 05:32:28 2010 216 0.000216

4 ETW000 [dev trc ,00000] db_con_init called 24 0.000240

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 51 0.000291

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/RP1/SYS/exe/run/dboraslib.so' ...

4 ETW000 56 0.000347

4 ETW000 [dev trc ,00000] Sat Aug 21 05:32:29 2010 185731 0.186078

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/RP1/SYS/exe/run/dboraslib.so), hdl 0

4 ETW000 9424 0.195502

4 ETW000 [dev trc ,00000] Library '/usr/sap/RP1/SYS/exe/run/dboraslib.so' loaded

4 ETW000 20 0.195522

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/RP1/SYS/exe/run/dboraslib.so

4 ETW000 58 0.195580

4 ETW000 [dev trc ,00000] Version of '/usr/sap/RP1/SYS/exe/run/dboraslib.so' is "640.00", patchlevel (0.220)

4 ETW000 160 0.195740

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/RP1/SYS/exe/run/dboraslib.so

4 ETW000 26 0.195766

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/RP1/SYS/exe/run/dboraslib.so

4 ETW000 67 0.195833

4 ETW000 [dev trc ,00000] New connection 0 created 37 0.195870

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 32 0.195902

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 39 0.195941

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 19 0.195960

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 20 0.195980

4 ETW000 [dev trc ,00000] Got ORACLE_HOME=/oracle/RP1/102_64 from environment

4 ETW000 265 0.196245

4 ETW000 [dev trc ,00000] -->oci_initialize (con_hdl=0) 36 0.196281

4 ETW000 [dev trc ,00000] got NLS_LANG='AMERICAN_AMERICA.WE8DEC' from environment

4 ETW000 19 0.196300

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIEnvCreate(mode=0)' failed: rc = -1

4 ETW000 59204 0.255504

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code -1 13 0.255517

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIErrorGet' failed: rc = -2

4 ETW000 482 0.255999

4 ETW000 [dblink ,00428] ***LOG BY2=>sql error -1 performing CON [dblink#3 @ 428]

4 ETW000 181 0.256180

4 ETW000 [dblink ,00428] ***LOG BY0=>Cannot get Oracle error text. [dblink#3 @ 428]

4 ETW000 19 0.256199

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'RP1'"

_________________________________________________________________________________________

There is one thing my Admin OS do, He copied file /oracle in TENR3P01 to TENR3P02.

my OS is HP UX 11.31 and SAP R/34.7 Oracle 10g

Thanx in Advance

Ros