Skip to Content
avatar image
Former Member

SAP only starts "half", no access possible

Hi all

I did a migration of three SAP instances to another server where two other SAP instances were already running. (SAP 4.6B, HP Unix 11.23)

The migration itself went fine up until the moment where I tried to access the SAP instance that was last migrated via SAP Client:

"WSAECONNREFUSED (10061) Connection refused".

The corresponding SAP instance started fine, no problems in the start log. DB therefore was also running fine.

What I discovered is, that some of the TCP ports of that SAP instance where not "open" (meaning, nothing behind them handling requests...):

PORT STATE SERVICE

3201/tcp closed unknown

3301/tcp closed unknown

3601/tcp open unknown

4801/tcp closed unknown

So, checking with ps -ef to see where the corresponding processes have gone, I only saw a few of the SAP processes that normally are running: ms.sapSID, se.sapSID, co.sapSID, /usr/sap/SID/SYS/exe/run/sapstart and 8 "ora_" processes. The list of processes of the other SAP instances fill more than one screen...

What I also discovered is the fact that when I stop the half started SAP instance, then stop one of the other properly running SAP instances, start the one that was "half" started again and AFTER that the one that run properly previously, then the situation has turned around:

- The previously fine running SAP instance, that now was started last, is not reachable, ports colsed & processes are missing.

- The previously "half" started SAP instance is now running fine.

That leads to the conclusion, that it is not the SAP instance itself that is "wrong". It has to be a shared resource that runs out of capacity during the fifth start of a SAP instances, regardless witch of the five. So when the fifth SAP instance comes up, it can not start completely as not enough of this resource is left over for it.

But what is this resource? And how can I change the consumption of it?

And again: Startlog does not tell me anything and after starting I got the message: "Instance on host ... started" No complains, no errors, no whatsoever....

Any ideas welcome!

Thanks!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 20, 2010 at 12:34 PM

    First thing that comes to my mind:

    Are system numbers different for your SAP instances?

    As you probably know, you cannot have two instances with the same number on one server.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Sergo Beradze

      Meanwhile I fixed it: SWAP!

      First I set the kernel parameters shmmax, shmmni and shmseg to the recommended values. (As SAP tried to allocate four chunks of 1024MB memory for a total aof 4092MB Extended Memory. But I think this has nothing to do with the solution. Only "cosmetics" ... 😉

      Then I had to set the kernel parameter swchunk from default 2048 to recommended 8192. Only with that it was possible to extend the SWAP.

      After reboot I assigned another 16GB logical volume to the SWAP space, now a total of 40GB.

      And now the fifth SAP instance starts fine (at leas in the test environment where I tried this out).

      Thanks a lot for all your help!

      About the 5 SAP instances on one server: The server is an HP Itanium rx2660, 2xCPU, 8GB RAM, productive SAP system has 50 something users, where two dozens are logged in simultaneously, where as only a handful of the logged in users are doing "serious" work in there (some finance, some purchase, some warehouse, ...). The other SAP instances (Validation, Test, Dev and a Sandbox) are used rarely. I guess at a time max two or three users logged in in any of them...

      So, server is mainly bored...

      Concerning SWAP: I know with the new total of 40GB I am still far bellow the by SAP recomenden 70GB SWAP space (20GB + 5 x 10GB). But it now runs with 40GB, all HDD slots are occupied, there are another 17GB not used I could assign to SWAP if needed. Only if no other things help we are going to exchange the current HDDs for larger ones!

      Edited by: Frank Huber on Aug 25, 2010 8:45 AM

      Edited by: Frank Huber on Aug 25, 2010 9:00 AM

  • Aug 20, 2010 at 02:02 PM

    First of all in situations like this check the logs dev_disp and dev_w0.

    Usually form this log's you find all errors and can find why your sap are Half runnig 😊

    Regards.

    Add comment
    10|10000 characters needed characters exceeded