Skip to Content
avatar image
Former Member

MDM Console

Greetings,

Can someone answer this question.

I have MDM 7.1 SP05 (MDS, MDSS, MDI) running on a SUSE 10 server. I also have Oracle 10.2.0.4 running on the same box.

On my windows laptop (Win XP sp3), I have installed the MDM Console 7.1.05.88) and I am able to mount the server which MDM is running. I can also go to the http port for MDM and start the admin console / snap in tool to see the MDM instances running.

However, when on my laptop, I can not create a repository / connect to the database. I have not been able to - ever. Though I did not find any information in the MDM install guide or the MDM Console guide, SAP says that I need to install the Oracle client on my laptop.

I have completed this; I am able to connect to the database on the MDM server (via sqlplus from windows). I have tried to use the system/manager userID to try to create the repository in the console.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • avatar image
    Former Member
    Aug 19, 2010 at 08:03 PM

    Hey,

    Do you have a 32 bit system or 64 bit?

    MDM 7.1 console can not be installed on 32 bit windows, you need 64 bit for that.

    You can install MDM 7.1 clients on 32 bit system though.

    Thanks

    Aamir

    Edited by: Aamir Suhail on Aug 20, 2010 8:53 AM

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 19, 2010 at 09:31 PM

    Hi,

    You DO NOT need to install Oracle client on your local laptop (client).

    As per my knowledge, if you have MDM server running on some different host then Database server then you need to install oracle client on MDM server. But not in any case installation of database client on your local system is required.

    Please let us know what error you are getting while creating repository/connecting to database?

    if it is just "error connecting database" then please check the MDM logs for more details of error.

    Best Regards,

    Shiv

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2010 at 05:59 AM

    Hi Jose,

    Note Following Point

    1. Right Click on MDM Server in Console and select DBMS Setting Option

    2. Select the server User name and Password try to connect to server

    3. if you are unable to connect to data base server which means your user ID and password are incorrect

    4. and data base user must have password and read/write permission

    5. also check data Path

    Above point may help you if not revert back with error details or MDS log file

    Thanks,

    Jignesh Patel

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2010 at 08:32 AM

    check your Laptop is Hardwired. some times t behaves differently with wi-Fi and hardwire.

    also check your Database setting and previleges given for a particular user who is connecting it with MDM system.

    Hope it helps.

    Deep

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 20, 2010 at 08:57 AM

    Hi,

    Are you able to connect to MDM server from you Local laptop...try to telnet from your Laptop

    go to run...type 'cmd' and in black window type

    telnet 'server IP' 'port code' for eg telnet 172.22.142.69 21...if this is connecting then there must be some other issue...if not you have to open the ports...contact your system administrator for the same.

    Cheers,

    Rc

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2010 at 12:39 PM

    Hi Guys -

    I'm looking at something similar ...

    @Aamir Suhail u2013

    Iu2019m looking at the download location :

    Support Packages and Patches - Entry by Application Group " -> SAP NetWeaver and complementary products " -> SAP MDM " -> SAP NETWEAVER MDM 7.1 " -> Entry by Component " -> Administration Clients

    Administration Clients

    • MDM CLIX 7.1

    >> Win32

    >>Windows Server on x64 64bit

    • MDM CONSOLE 7.1

    >> Win32

    The console only comes in Win 32 u2026

    @ Shiv Prashant

    The errors that I am seeing after I mount the MDM server and try to create a repository is:

    [excerpt]

    ERROR CODE=-1 ||| Failed to intitialize Oracle shared library.

    Last CMD: OCIErrorGet: pfnOCIErrorGet==NULL

    OCI Init returned 0x84020028

    Oracle Initialization Failed -- likely missing libraries/dlls

    [/excerpt]

    Iu2019m not clear on the last statement u2013 WHICH Oracle libraries? On the MDM Server that is housing the Oracle database?

    On the laptop which is trying to connect to MDM (which I am leaning towards).

    As a note: I did follow SAP note 1250319 and used InfoMds scripts for validation. As far as I can tell, the params and checks passed. I ran the script as MDM OS user ID and the Oracle OS user ID with the u201C u2013ou201D option for the database connections.

    @ jignesh patel

    As a note, I am using u2018system/masteru2019 and an MDM user I created in Oracle. With both users, I can access the database from the different laptops or on the server itself via the sqlplus command. According to the Install Guide for the MDM Server and the Console Guide, it starts by saying that you need to use SYSTEM or some similar user to begin.

    Not sure what you mean on point 5 (also check Path). What path are you referring to?

    @ Rajesh Chavan

    Port 21 is turned off and Iu2019m not sure why you would need that; I AM able to telnet to the MDM server ports and get a connection.

    Few things:

    • If SAP is saying that you need to install Oracle client on my laptop, is this something that any of you were told to do?

    • What libraries would I need (or, the MDM server running the database) that are not being recognized when connecting?

    • Is there a way to test using CLIX (Win 32)?

    Thanks!

    -s

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2010 at 01:55 PM

    I take that back, the constraints are:

    Clients (Console, Data Manager etc) - can be installed on 32 bit.

    Servers (MDS, MDIS, MDSS) - Need 64 bit.

    Thanks

    Aamir

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 04, 2010 at 03:41 PM

    Team -

    Going to close this thread. Just wanted to put my .02 cents in to outline what was finally

    done.

    • The install for MDM was successful. We did the install a few times, but the

    results were the same.

    • We are running Oracle 10.2.0.4 on Suse 10 in a VM environment.

    The issue that we saw initially was that Oracle was installed before the MDM

    application. Even thought that MDM and Oracle was working, there seemed

    to be some thing broken. (Note: the MDM install documentation did say to

    install MDM before the database). This will have to be revisited because

    going forward our systems will be on HA systems; just have to coordinate this

    with the DBA teams.

    • For connection to the MDM Console, we are using this method:

    For the server, we identified the server (example: saptestmdm.domain.com)

    For each repository, we did the following:

    DBMS Server: FQDN:(port)/SID [Oracle]

    Example: DBMS Server: saptestmdm.domian.com:1521/MDM [Oracle]

    Username: mdmuser (same Oracle privs as SYSTEM)

    Password: *****

    After we saved the configuration to a .msc file, I didn't have to do this afterwards.

    Same concept for the Import Manager.

    Type: Oracle

    Remote System: MDM

    DBMS Server: sapmdmtest:1521/MDM

    Database: (the repository you want to look at) MDMTEST001_M000

    User: mdmuser

    Password: *****

    Last point - do make sure that the version of the clients are the lastest version.

    I had to chase a red herring because one user's client was at 7.1.0.5.85 (console mgr)

    and the version I ran (working) was at 7.1.0.5.88; my Import Mgr is at 7.1.0.5.89.

    A note from SAP:

    When I created this ticket, I got a few pointers (including the RTFM from the install doc).

    That said, the above method for connecting is not in the install doc manual. It's not

    clear in the MDM Console Reference Guide (7.1), either. As far as I can tell, the

    person on my OSS message did not connect the way that I demonstrated above.

    I don't know why I have to do it this way, or, if SAP (and anyone else) had to use

    a different approach.

    Sorry for the delay in updating this. This thread can be closed.

    Thanks!

    -s

    Add comment
    10|10000 characters needed characters exceeded