Skip to Content

DBIF_RSQL_SQL_ERROR : With Maxdb 7.6

Hi,

Yesterday I had installed New Dialog instance for load Sharing after starting that instance i started getting Following Runtime error.

Runtime Errors DBIF_RSQL_SQL_ERROR

Exception CX_SY_OPEN_SQL_DB

And in how to correct section, I am getting following :

How to correct the error

Database error text........: "Connection failed (RTE:[2] too many database

sessions active)"

Internal call code.........: "[RSQL/DELE/PAKDATBUF ]"

Please check the entries in the system log (Transaction SM21).

If the error occures in a non-modified SAP program, you may be able to

find an interim solution in an SAP Note.

If you have access to SAP Notes, carry out a search with the following

keywords:

"DBIF_RSQL_SQL_ERROR" "CX_SY_OPEN_SQL_DB"

"SAPLPA_PACKAGE_SERVICES" or "LPA_PACKAGE_SERVICESF02"

"WRITE_TO_DATABASE"

I had checked MAXDB Parameter MAXUSERTASKS, and in my system its defined as 50.

currently at any time in my system, nos. of people loged in is always around 90 to 100.

Kindly sugest me Do i need to change this parameter?

What other parameters are to be changed?

Following is my current Parameter Settings:

CACHE_SIZE 349312

INSTANCE_TYPE OLTP

KERNELVERSION KERNEL 7.6.05 BUILD 015-123-202-938

LOG_MIRRORED NO

LOG_SEGMENT_SIZE 213333

MAXBACKUPDEVS 2

MAXCPU 2

MAXDATAVOLUMES 31

MAXLOCKS 300000

MAXLOGVOLUMES 6

MAXUSERTASKS 50

Regards,

Ritesh

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 20, 2010 at 04:44 PM

    Hi,

    it is not important how many users you have , but how many connections they can open.

    For example for SAP ABAP stack you should set this parameter :

    MAXUSERTASKS = 2 x <number of workprocesses> + 4

    Regards

    ivan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 22, 2010 at 11:28 AM

    Dear Ivan Levrinc ,

    Thanks for the solution,

    I had increased the database sessions by folloing :

    2 x WP+4

    and now system is working fine.

    Regards,

    Ritesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 22, 2013 at 01:34 AM

    This is the correct answer. Goto /nLC10 and change the parameter there. Then restart LiveCahce to have the changes take effect.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.