Skip to Content
avatar image
Former Member

Re-run availability check in Sales Order on the new SLoc determined by MV45AFZZ

Hi Experts,

We were already to determine the sloc on the sales order line items by utilizing USEREXIT_SAVE_DOCUMENT_PREPARE in MV45AFZZ.

The Sloc is already being updated whenever the document is being saved after the shipping condition is changed (this is a client business process to eliminate per line item change in Sloc).

But we are having issues on the stock availability. Availability check was still performed on the old sloc and not on the new sloc.

Is there a way the sales order will run availability check again on the new sloc determined by USEREXIT_SAVE_DOCUMENT_PREPARE in MV45AFZZ upon saving?

Thanks in advance for your advice.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 05, 2016 at 07:41 AM

    Hello,

    I believe MV45AFZB USEREXIT_SOURCE_DETERMIN being used to determine Sloc,which will determine Sloc and perform availability check.

    Br,

    Vishal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Vishal,

      Thank you for this. We changed the userexit we used from "USEREXIT_SAVE_DOCUMENT_PREPARE" in MV45AFZZ to "USEREXIT_CHECK_VBAP" in MV45AFZB.

      It works as intended. When shipping condition is changed, the SLoc gets updated on the line item. The problem I now get is this:

      When a sales order is being created, the Sloc already is being determined on the Sales Order. But upon Saving, it doesn't run the Availability Check on Sloc level on the determined sloc but on Plant Level only. I assume the availability check is still considering the sloc as blank. I need to redetermine availability or try to change the qty for the sales order to check the stocks on Sloc level.

      Did we miss something?

  • Dec 12, 2016 at 07:56 AM

    Hello,

    Check in you availability check control if it is ticked for storage location inspection.

    Ideally it should be unchecked.

    Br,

    Vishal

    Add comment
    10|10000 characters needed characters exceeded