Skip to Content
avatar image
Former Member

Catalog View Problem

Dear all,

We are currently facing a strange problem with the catalog view for one of our webshop. Might be a good brain teaser for you, kindly help

Following is the Problem scenario

When users login to quality environment ISA determines and selects the correct view to be displayed. However, in production when same user logs in he sees all prducts from different catalog views as well.

Quality Envrionment ->

Shop settings have Catalog Search checkbox enabled.

Catalog, Catalog Variant, catalog View are defined same as in SAP CRM Quality environment.

Production Environment ->

Shop settings have Catalog Search checkbox enabled.

Catalog, Catalog Variant, catalog View are defined same as in SAP CRM Production environment.

Quality Environment Code and Production code are the same and so are the shop settings as well as CRM product catalog settings. Business partner defined for this catalog view are the same for both environment.

Any idea what could be the problem?

Best regards,

-Tarun

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Aug 19, 2010 at 04:19 PM

    Hi there,

    It could be the case that the user is assigned to more then one catalog view, you can use the function module CRM_ISA_PCAT_GETFROMBUPA to check what views are been returned for a user.

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Mark,

      Thanks for your reply, Although very late I just though of updating on the forum that we checked the FM mentioned by you, we have a extension to this FM and observed that the path taken while FM during execution was very different from path taken in prod. Therefore, we waited for data refresh to happen in Quality and replicated the issue. Though we haven't been able to find root cause we have been able to put a filter for a particular shop_id in this custom FM. The problem is rectified now with a bit of tweak.

      Thanks,

      -Tarun

  • avatar image
    Former Member
    Aug 19, 2010 at 03:19 PM

    Hi ,

    Pllease check if this BP is also assigned in more than one catalog views ,

    Also please check whether the BP is part of target group ( which is assigned in catalog view ) in production system

    thanks and regards,

    PD

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 07, 2010 at 08:47 AM

    Hi,

    The issue can occur if not assigned any catalog view for the shop in the production server.

    or

    If any collaborative views are assigned to the sold to party which you logged in.

    Thanks and Regards,

    Dinesh.

    Add comment
    10|10000 characters needed characters exceeded