Skip to Content
avatar image
Former Member

Printing multiple copies of a document on a remote network printer queue

Hello,

We have migrated our main production instance (ECC6) from HP-UX to AIX 6.1, went live on monday.

Printers are defined like this:

SAP prints to the local operating system (C)

Local print queues are defined which point to remote printers still currently located on a HP UX server. Nothing was changed on this one.

Now since the migration on AIX, the parameter for multiple copies of a document is ignored, if we select for example 4 copies on the SAP print screen, only 1 copy is printed. It worked perfectly fine when the instance was on HP UX.

Seems that the lp command on AIX does not pass the optional parameters when printing on a remote printer (was acknowledged by AIX support), and if we issue manually on AIX a lp command with parameter -n2 for example, only one copy is indeed printed.

I wonder if there is a simple workaround to this problem since it must be quite common? I didn't find anything here or in the Sap notes.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 12, 2010 at 09:22 AM

    Is that happening with no of pages also ? I mean you print a document of 8 pages but you only get 2 copies.. don't know if they relate to SAPScript for this.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 12, 2010 at 11:02 AM

    Tried using the 'lpr' command instead ? Another option would be to install [CUPS|http://www.cups.org/].

    Nelis

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks, but the idea is to get it to work without additional products since it worked fine under HP UX.

      Seems the AIX administrator has found a workaround with modifying the queue definitions in qconfig, to be BSD style... tests in progress 😊