Skip to Content

SMSY has multiple entries for servers and databases.

We recently upgrade from 3.2 to 7.0. Solution Manager is the host SLD. I've setup the SDCCN on the landscape systems to send data to the SLD.

Previous to the upgrade we used RFC/TMS to gather info. On 3 of the systems we use named instances for the SQL Server. Now, when the landscape fetch runs there are entries under the Servers using the named instance name, and under teh Datbases an entry for the DB with a suffix of 0001.

For example:

Server: SAPTST01 Data source Manual (or RFC for one of them)

Database: TS1

(new entry)

Server: saptst01\sapdb_ts Data source SLD

Database TST1_0001

In each of these case original server name is in UPPERCASE and the new entry is lowercase.

I have tried deleting those entries from SMSY, but they repopulate when the landscape_fetch runs.

What, where and how do I make adjustment so that the incorrect (named instance name) servers and extra database entries stop showing up in SMSY?

I'm not sure of the impact of having these is. The correct entries are still there. Just seems to me something isn't quite setup right yet tho.

Thanks for you ideas and help.

Laurie McGinley

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Aug 06, 2010 at 05:49 PM

    Depending of your SP level you'll have some corrections to be applied, for this reason it's highly recommended have always the latest SP level.

    1) Remove all entries duplicated and the original entries in SMSY

    2) Check these two notes below and apply them.

    SV-SMG-SYS 1299281 SMSY: Systems created with _0001 or _NABP

    SV-SMG-SYS 1295422 SMSY: Duplicate database created

    3) Run LAndscape Fetch again.

    This issue will be solved.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Mateus, we are at stack 21, the package is newer then the one reference in those notes, although 1295422 does sound/look like what is happening.

      I'll delete the extra databases again. What I didn't do before was remove the existing entries. I'll look into that and see what I can do there.

      Sunny, the note references components, which doesn't seem to be the issue for me near as I can tell

      Thanks 😉

      Edited by: Laurie McGinley on Aug 6, 2010 2:36 PM

  • Aug 09, 2010 at 04:05 PM

    Hello Laurie, while you don't delete these systems, you'll not be able to solve this issue. Please, double check my recommendations.

    Add comment
    10|10000 characters needed characters exceeded

    • The result has been that the extract database xxx_0001 have not been recreated, so that is good. The correct databases however reference the named instance entry in the Servers list.

      So:

      Server:

      SAPDEV01 (server host name)

      sapdev01\sapdb_dv (sql server instance name)

      Database:

      DV1 references sapdev01\sapdb_dv

      Don't think this is quite correct, but if that is how smsy handles sql server named instances, then I'll live with it until I find something that isn't working correctly.

      Laurie 😉

  • avatar image
    Former Member
    Aug 06, 2010 at 04:54 PM

    Hi,

    Check SAP Note 1429764 - Automatic assignment of products in SMSY

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 07, 2010 at 02:40 PM

    Hello Laurie

    What were the results ?

    Add comment
    10|10000 characters needed characters exceeded

    • Good morning Mateus. The result is a mixed bag.

      I didn't delete any of the systems. But did delete the extra database and servers.

      I got back 2 of the extra databases, and all three of the extra servers.

      I think i just need to focus on one of the systems, the sandbox, and start it from scratch in smsy. Drop the system, the database, the server and rerun landscape_fetch and see what happens.

      Laurie 😉