Skip to Content
author's profile photo Former Member
Former Member

Logon fail when creating Connection in Crystal Reports SP3

Greetings,

I am working on an issue where we have installed the SAP GUI 7.10, Crystal reports 2008 SP3, and SAP IK FP 3.1.

We are testing the access to ECC. We have setup the server in the GUI and can successfully logon to the server in the GUI. We open Crystal Reports, select File -> New -> Standard Report, scroll down to SAP Table, Cluster, or Function, and the SAP System Logon window pops up.

Select the ECC system, click Next, and input the logon info for the system. Click Next and do not check the box for generating a RFC trace file, then click finish.

This results in a new window popping up. The title is Crystal Reports, and the contents of the window are as follows...

Logon failed.

Details: <bunch of Chinese characters>.<more Chinese characters>

We are using the language setting of EN on the SAP server, and in the GUI configuration. Not sure why we are getting Chinese (we have verified it as Chinese with a person here who can read some Chinese. he says that the first part is "something about server not valid")

We asked a user who does have a working install using CR 2K8 SP2 and SAP IK SP2 to try the login and he had the same results on this system.

We can use the same SAP account to login to InfoView without an issue.

Any suggestions?

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 05, 2010 at 06:55 PM

    Solution found.

    Despite a hard rule to always reboot after applying patches we apparently did not do this. After rebooting the workstation it started working with no issue.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Andy,

      I'm having similar kind of issue but did not get any Chinese symbols, something like (multiple)square symbols.(multiple) square symbols... Rebooting did not help me.

      Can you please share what all configuration settings have to done before you tried to login from Crystal to SAP ECC environment.

      Thanks,

      Madhu

  • author's profile photo Former Member
    Former Member
    Posted on Sep 01, 2011 at 08:58 PM

    Hi Madhu,

    Can you please tell me how you fix this issue?? i have the same error when i try to connect to ECC with Crystal Report. I reboot the machine but nothing happend..

    Any help will apreciated,

    Greetings

    Guillermo

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      i had the same problem.

      it has something to do with the sap gui logon settings.

      1. go to your SAP logon ECC-properties (start sap-logon; right-click on your ecc connection)

      2. go to the Codepage-Tab

      3. set Language to default (standard)

      then it should work.

      br

      thomas

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.