Skip to Content

C4C Why not all relationships are well replicated from CRM to C4C

Hi,

I have loaded different partners from SAP CRM into C4C; like sold to, ship to, bill to etc.

I use one cusotmer type and defined several customer roles.

Loading the partners goes quite well.

Relationships how ever are not all loaded succesfully, especially when a customer has multiple bill to and ship to addresses.

Only one relation of a type is crreated succesfully, for the others i get the message: Error while processing inbound third party communication | Partner has more than one relationshp of category Ship-to Party relationship with DEFAULT_INDICATOR set.

But there are no default indicators set on the partners nor the relationships in SAP CRM.

What is the best thing to do? Alter the (standard) outbound idoc message?

Looking forward to your experiences.

Kr.

MJ

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Feb 21, 2019 at 02:49 PM

    Hi,

    I have solved this by adding the main indicator on the relationship.

    As I was not able to change the standaard relationships, i had to create z- relationships and changed the code list mapping.

    https://apps.support.sap.com/sap/support/knowledge/public/en/2697536

    Kr.

    MJ

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.