Skip to Content
0

SAP PO Java only Linux/Sybase. Error: ​Resource setting ‘max memory size’ is incorrect

Dec 02, 2016 at 04:54 PM

377

avatar image
Former Member
Hi Gurus, I have the following problem: My SUSE version is : SUSE Linux Enterprise Server 11 (x86_64) VERSION = 11 PATCHLEVEL = 4
I am installing SAP Process Orchestation (SAP PO) with SAP Netweaver 7.5 (Java Only). 
I run my sapinst and in Phase 8 of 31, I get following error: Assertion failed: Resource setting ‘max memory size’ is incorrect; refer to the installation documentation to solve this.
I read some notes and comments on SDN, and there are two parameters: kernel.shmmax and kernel.shmall in /etc/sysctl.conf 
This note: 941735 - SAP memory management system for 64-bit Linux systems indicates that parameters generally do not move them.
My server: 16 GB in RAM My mounted directories and spaces:
# df -BG 
Filesystem 1G-blocks Used Available Use%Mounted on 
rootfs 10G 5G 5G 49% / 
udev 8G 1G 8G 1% /dev 
tmpfs 8G 1G 8G 1% /dev/shm 
/dev/hda1 10G 5G 5G 49% /
/dev/xvdg 50G 27G 24G 53% 
/mediossap /dev/xvdh 200G 1G 200G 1% 
/backup /dev/xvdi 300G 1G 300G 1% 
/sybase /dev/xvdj 60G 1G 60G 1% /usr/sap
Al my SWPM installer have 777 as privilege and my /temp .
I did following: 
Create parameter kernel.shmmax to 15.000.000.000 in file /etc/sysctl.conf, restart my server and run again sapinst. Error continue but another message about recently parameter implemented: Assertion failed: Linux kernel setting ‘kernel.shmmax’ is incorrect; refer to the installation documentation to solve this.
Later, I modify kernel.shmmax to diferent values, like: kernel.shmmax=16.000.000.000 Same error: Linux kernel setting ‘kernel.shmmax’ is incorrect; refer to the installation documentation to solve this 
Modify to : kernel.shmmax=16.590.564.472 Same error: Linux kernel setting ‘kernel.shmmax’ is incorrect; refer to the installation documentation to solve this
Modify to : kernel.shmmax=7.590.564.472 
This because my shared memory coul be less than /dev/shm (8GB) 
Same error: Linux kernel setting ‘kernel.shmmax’ is incorrect; refer to the installation documentation to solve this. 
Modify to : kernel.shmmax=16.591.351.808 This error: Standard System( Last error reported by the step: Assertion failed: Resource setting 'max memory size' is incorrect; refer to the installation documentation to solve this.). 
Total parameters:
XXXXX:~ # sysctl -p net
.ipv4.icmp_echo_ignore_broadcasts = 1 
net.ipv4.conf.all.rp_filter = 1 
fs.inotify.max_user_watches = 65536
net.ipv4.conf.default.promote_secondaries = 1 
net.ipv4.conf.all.promote_secondaries = 1 
fs.file-max = 20000000 
fs.aio-max-nr = 196608 
vm.memory_failure_early_kill = 1
kernel.shmmni = 65536 
vm.max_map_count = 13100000 
net.ipv4.ip_local_port_range = 40000 65300 
kernel.shmmax = 16591351808 
XXXXX:~ # 
I think because no sybase is installed yet, the problem is not about database, is in operating system. 
I read following notes, but they are irrelevant, no information about my error: 1722359 - SYB: Running SAP applications on SAP ASE - Best Practice 1680803 - SYB: SAP Adaptive Server Enterprise - Best Practice for SAP Business Suite and SAP BW 1539124 - SYB: Database Configuration for SAP applications on SAP ASE 1581695 - SYB: Configuration Guide for SAP ASE 16.0 1889468 - SAP installer fails at step "Configure Database Server" on SAP ASE for BS 1837579 - SYB: SAP installer fails at step "Configure Database Server" 
Please if you have any suggestion, you are welcome. 
Thanks.
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
avatar image
Former Member Dec 02, 2016 at 11:32 PM
1
Hi, I solved my problem with following:


First, the parameter kernel.shmmax I leave it just by
default, I dont modify and I dont create it. Just like note: 941735 indicates.


I read SAP Netweaver installation guide 7.4 and this note: 1704753
- Inst.Systems Based on NetWeaver on UNIX.


 


In this note references to parameters:


“Using sh or ksh shell, the output* of command 'ulimit -a'
needs to be at least as follows: “ …


My parameters max memory size had a value of: 13772124. I
change it to unlimited with this command:


#ulimit –m unlimited


I ran again sapinst an now show me another error: ERROR: Resource
setting 'virtual memory' is incorrect; refer to the installation documentation
to solve this.)


 


I executed:


#ulimit –v unlimited


I ran again sapinst in same putty sesión and fine, I can
install.


Important, I did not reboot my server, because if I reboot,
I loose my commands.


I install and fine.


Thanks, I hope can help you.


 
Share
10 |10000 characters needed characters left characters exceeded