Skip to Content

SAP Solution Manager Configuration under the system preparation

Hello Folks,

We are performing mandatory configuration .Under the Infrastructure preparation -->Setup java connectivity-->2.2 Enable connectivity for "check Java software prerequisite" step we are getting the error as "LM-SERVICE component does not have expected level (current:7.20 SP=7, expected 7.20 SP=005)"

Our solution Manager version is on 7.2 SP05 and i have found that there is bug in this version for the above error. SAP has release one SAP note 2294619 for this issue but it is not applicable to my system version.

Anyone came across this issue, please help me out.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Feb 18 at 09:44 PM

    Please refer SAP Note 2362338 and update to latest version of LM-Service. Hope this helps

    -Giri

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 19 at 04:37 AM

    Hi Giri,

    Resolution given under the note which you have referred is to implement correction from 2294619 and the status of it is cannot be implemented.

    LM-SERVICE version in the system is the updated one i.e 7.20 SP07.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 19 at 03:34 PM

    could you please share your installed software versions & solman version.

    -giri

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21 at 06:44 AM

    LM-SERVICE version is 1000.7.20.7.0.20180413094800

    Solution Manger Version is 7.2 SP 05

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21 at 04:40 PM

    Hi Keerthi,

    I think note 2688407 might apply. It states your LM-SERVICE must be at the same patch level as your ABAP ST.

    Good luck.

    Mike

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Keerthi,

      My suggestion was to upgrade LM-SERVICE or ST, whichever is lower. I think Jan's suggestion is maybe better. We are currently upgrading from SP05 to SP08 and hope it only take a couple of months for all three Solution Manager systems.

      Thanks,

      Mike

  • Feb 22 at 09:39 AM

    Hi Mike,

    Thanks for providing the SAP note number.

    We cannot downgrade our LM-SERVICE version now, is there any harm if we continue with the current version of LM_SERVICE.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22 at 11:09 AM

    Hi Mike,

    Thanks for providing the SAP note.

    Currently we cannot downgrade the patch of LM-SERVICE , we want to continue with the current version is there any issues we could come across if did not downgrade it?

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 07 at 01:31 PM

    Hi keerthi,

    I would strongly suggest updating your solution manager (both ABAP and JAVA) to SP08, which would be required since start of the next year anyway. (Because 8 is great!)

    Of course, if you are updating LM service, you should always choose patch level to your current SP level.

    Jan

    Add comment
    10|10000 characters needed characters exceeded