Skip to Content

CSV/Excel-Export does not respect regional settings?

Environment: SAC on BW 7.50 SP11 on HANA

I´ve created the following simple table in SAC which I want to export to CSV (Excel).

Please note that my whole system (Windows, Excel, …) is in German with corresponding regional settings, means thousands separator is . and comma separator is ,

This is exactly how the settings are in SAC:

When I export now the table from SAC with following settings …

... and open the exported downloaded file in Excel I get the following not usable format:

From my point of view the SAC doesn´t respect the regional settings.

This is the SAC CSV export file opened in notepad:

If I create the same data in Excel, save it as CSV file and open it then in notepad the correct format looks like this:

I seems to me that SAC export is not considering regional settings, at least German format.

Can anybody confirm?

Regards,

Thomas

pic1.png (37.1 kB)
pic2.png (22.7 kB)
pic3.png (19.8 kB)
pic4.png (7.0 kB)
pic5.png (5.4 kB)
pic6.png (4.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Feb 28, 2019 at 01:50 PM

    Dear Thomas,

    That looks strange in multiple respects to me. First, the generated CSV looks odd in terms of where quotation marks " are placed. In our internal system, the CSV looks correct, values are properly enclosed by quotation marks ".

    Second, the user preference setting for Number Formatting is picked up properly by CSV export in our internal validation system.

    I tend to assume that the functionality is broken in your system, you may consider creating a support ticket for this. In any case, it appears to me fixed in the current version.

    Furthermore, my observation is that Excel by default imports numbers correctly as numbers (and not as strings) only when a comma is used as decimal separator, which is the case for German number formats. (This fact actually appears independent of the Windows Region⟪uage setting of the computer, which surprised me a bit.). To handle numbers in other formats properly however, there is a advanced setting in Excel when importing data from text, which would Excel let recognize numbers in CSV properly.

    I hope that helps.

    Regards, Christoph


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.