Skip to Content
0
Former Member
Jul 28, 2010 at 09:50 AM

ISSUE with OPS$ and SAPSR3DB

181 Views

Hi All,

SYSTEM : EP 7.0

Database: oracle 10g

OS : windows

We are facing problem with OPS$EPDADM and SAPSR3DB users while trying to connect to the database using brtools.

When we do R3trans -d we are gettng Return code 12.Please find the details trans.log

________________________________________________________________

4 ETW000 R3trans version 6.14 (release 701 - 05.03.09 - 08:28:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 28.07.2010 - 15:06:08

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Wed Jul 28 15:06:10 2010 0 0.000000

4 ETW000 [dev trc ,00000] db_con_init called 0 0.000000

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 0 0.000000

4 ETW000 [dev trc ,00000] Loading DB library 'dboraslib.dll' ... 0 0.000000

4 ETW000 [dev trc ,00000] load shared library (dboraslib.dll), hdl 0, addr 11490000 43607 0.043607

4 ETW000 [dev trc ,00000] using "G:\usr\sap\EPD\SYS\exe\uc\NTI386\dboraslib.dll" 163 0.043770

4 ETW000 [dev trc ,00000] Library 'dboraslib.dll' loaded 54 0.043824

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library dboraslib.dll 54 0.043878

4 ETW000 [dev trc ,00000] Version of 'dboraslib.dll' is "700.08", patchlevel (0.38) 246 0.044124

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library dboraslib.dll 67 0.044191

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library dboraslib.dll 85 0.044276

4 ETW000 [dev trc ,00000] New connection 0 created 96 0.044372

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 109 0.044481

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 91 0.044572

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse: 50 0.044622

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 98 0.044720

4 ETW000 [dev trc ,00000] CLIENT_ORACLE_HOME is not set as environment variable or 824 0.045544

4 ETW000 DIR_CLIENT_ORAHOME is not set as profile parameter.

4 ETW000 assuming using instant client with unspecified location.

4 ETW000 [dev trc ,00000] Wed Jul 28 15:06:11 2010 112376 0.157920

4 ETW000 [dev trc ,00000] Oracle Client Version: '10.2.0.1.0' 115 0.158035

4 ETW000 [dev trc ,00000] -->oci_initialize(con_hdl=0, char='', nchar='') 72 0.158107

4 ETW000 [dev trc ,00000] application info callback registered 81 0.158188

4 ETW000 [dev trc ,00000] OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)

4 ETW000 16327 0.174515

4 ETW000 [dev trc ,00000] Client character set UTF16 -> UTF8 615 0.175130

4 ETW000 [dev trc ,00000] Client NLS setting (OCINlsGetInfo): connection handle 0 -> 'AMERICAN_AMERICA.UTF8'

4 ETW000 171 0.175301

4 ETW000 [dev trc ,00000] charset='', chset='UTF8', UNI_ASC=FALSE/FALSE 71 0.175372

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPSR3DB's password 367 0.175739

4 ETW000 [dev trc ,00000] Connecting as /@EPD on connection 0 (nls_hdl 0) ... (dbsl 701 270309)

4 ETW000 142 0.175881

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet EnvHp ErrHp ErrHpBatch

4 ETW000 109 0.175990

4 ETW000 [dev trc ,00000] 0 UTF8 02DD25A0 02DD7AD4 02DD735C

4 ETW000 108 0.176098

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 84 0.176182

4 ETW000 [dev trc ,00000] Allocating server context handle 92 0.176274

4 ETW000 [dev trc ,00000] Attaching to DB Server EPD (con_hdl=0,svchp=02DD72A8,srvhp=02DDA544)

4 ETW000 297 0.176571

4 ETW000 [dev trc ,00000] Assigning server context 02DDA544 to service context 02DD72A8 170149 0.346720

4 ETW000 [dev trc ,00000] Allocating user session handle 179 0.346899

4 ETW000 [dev trc ,00000] Starting user session: OCISessionBegin(con_hdl=0, usr='/',svchp=02DD72A8, srvhp=02DDA544, usrhp=02DE54F0)

4 ETW000 152 0.347051

4 ETW000 [dev trc ,00000] Assigning user session 02DE54F0 to service context 02DD72A8 121379 0.468430

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con_hdl=0, len=52, stmth_p=02DE2380) 5043 0.473473

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1);END;

4 ETW000 166 0.473639

4 ETW000 [dev trc ,00000] CbApplInfoGet() failed (ignored 1). 311 0.473950

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con_hdl=0, len=54, stmth_p=02DE33B0) 107 0.474057

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;

4 ETW000 100 0.474157

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=02DE1338) 2693 0.476850

4 ETW000 [dev trc ,00000] SELECT SID FROM V$MYSTAT WHERE ROWNUM<2

4 ETW000 215 0.477065

4 ETW000 [dev trc ,00000] Connected to session 158. 2897 0.479962

4 ETW000 [dev trc ,00000] Now '/@EPD' is connected: con_hdl=0, nls_hdl=0, session_id=158. 148 0.480110

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=02DE1338) 300 0.480410

4 ETW000 [dev trc ,00000] ALTER SESSION SET NLS_SORT = BINARY

4 ETW000 200 0.480610

4 ETW000 [dev trc ,00000] -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=02DE1338) 3473 0.484083

4 ETW000 [dev trc ,00000] SELECT USERID,PASSWD FROM SAPUSER WHERE USERID IN (:A0,:A1)

4 ETW000 184 0.484267

4 ETW000 [dev trc ,00000] OCIStmtExecute() failed with -1=OCI_ERROR 23245 0.507512

4 ETW000 [dev trc ,00000] SQL error 942: 123 0.507635

4 ETW000 [dev trc ,00000] ORA-00942: table or view does not exist

4 ETW000 114 0.507749

4 ETW000 [dbsloci. ,00000] *** ERROR => ORA-942 when accessing table SAPUSER 102 0.507851

4 ETW000 [dev trc ,00000] set_ocica() -> SQL error code 942 79 0.507930

4 ETW000 [dev trc ,00000] -->oci_get_errmsg (con_hdl=0, rc=942) 70 0.508000

4 ETW000 [dev trc ,00000] OCIErrorGet -> SQL error code: 942 241 0.508241

4 ETW000 [dev trc ,00000] ORA-00942: table or view does not exist

4 ETW000 109 0.508350

4 ETW000 [dev trc ,00000] Disconnecting from connection 0 ... 64 0.508414

4 ETW000 [dev trc ,00000] Rolling back transaction ... 178 0.508592

4 ETW000 [dev trc ,00000] Closing user session (con_hdl=0,svchp=02DD72A8,usrhp=02DE54F0) 1819 0.510411

4 ETW000 [dev trc ,00000] Now I'm disconnected from ORACLE 2608 0.513019

4 ETW000 [dev trc ,00000] Try to connect with default password 116 0.513135

4 ETW000 [dev trc ,00000] Connecting as SAPSR3DB/<pwd>@EPD on connection 0 (nls_hdl 0) ... (dbsl 701 270309)

4 ETW000 98 0.513233

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet EnvHp ErrHp ErrHpBatch

4 ETW000 91 0.513324

4 ETW000 [dev trc ,00000] 0 UTF8 02DD25A0 02DD7AD4 02DD735C

4 ETW000 97 0.513421

4 ETW000 [dev trc ,00000] Assigning username to user session: con_hdl=0, usrhp=02DE54F0 62 0.513483

4 ETW000 [dev trc ,00000] Assigning password to user session: con_hdl=0, usrhp=02DE54F0 202 0.513685

4 ETW000 [dev trc ,00000] Starting user session: OCISessionBegin(con_hdl=0, usr=SAPSR3DB/<pwd>, svchp=02DD72A8, srvhp=02DDA544, usrhp=02DE54F0)

4 ETW000 120 0.513805

4 ETW000 [dev trc ,00000] OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR 41682 0.555487

4 ETW000 [dev trc ,00000] OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017: 312 0.555799

4 ETW000 [dev trc ,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 112 0.555911

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '1017' 83 0.555994

4 ETW000 [dev trc ,00000] set_ocica() -> SQL error code 1017 59 0.556053

4 ETW000 [dev trc ,00000] -->oci_get_errmsg (con_hdl=0, rc=1017) 57 0.556110

4 ETW000 [dev trc ,00000] OCIErrorGet -> SQL error code: 1017 340 0.556450

4 ETW000 [dev trc ,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 139 0.556589

4 ETW000 [dblink ,00431] ***LOG BY2=>sql error 1017 performing CON [dblink#3 @ 431] 168 0.556757

4 ETW000 [dblink ,00431] ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#3 @ 431]

4 ETW000 1977 0.558734

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'EPD'"

Edited by: Deepu Rajendrababu on Jul 28, 2010 11:50 AM