Skip to Content
avatar image
Former Member

Messages getting stuck in SMQ2

Messages get stuck in SMQ2 with the Error msg "SQL error on database occurred when accessing a table".

This is happening on PI system 7.11 SP04 with Max DB version 7.7.06.07.

This typically happens when sending messages from one BPM to another although it has more of a random pattern.

A corresponding dump is also seen in ST22.

The dump details are as below:

Runtime error : DBIF_RSQL_SQL_ERROR

Exception : CX_SY_OPEN_SQL_DB

Database error text : Invalid numeric value for parameter/column (10)

Internal call code : "[RSQL/UPDT/SWFRXIHDR ]"

Any help is highly appreciated in resolving this issue.

Regards,

Murali Narayanan

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Jul 27, 2010 at 04:18 PM

    > The dump details are as below:

    > Runtime error : DBIF_RSQL_SQL_ERROR

    > Exception : CX_SY_OPEN_SQL_DB

    > Database error text : Invalid numeric value for parameter/column (10)

    I would update the kernel (plus the database interface library lib_dbsl) to the latest patchlevels and try again. If the error persists I'd upgrade the database to the latest patchlevel. If it still doesn't work I'd open an OSS call (BC-DB-SDB).

    Markus

    .

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 27, 2010 at 06:04 PM

    SAP Note says that when you activate the BALANCING parameter in TUNING category in SXMB_ADM --> Integration Engine then you would get the above error....(check if something similar is set in your system also)....some more information is given in this note: https://service.sap.com/sap/support/notes/1129867

    Correction is available....but it is for SAP PI7.1

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2010 at 12:12 PM

    Hi ,

    Thanks for your replies.

    Updating the Kernel and lib_dbsl to the latest patch level has not helped.

    The issue is still prevelant.

    Any other suggestions regarding the approach for the issue shall be very helpful

    Regards,

    Murali Narayanan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Markus Doehr

      Hi All,

      I was able to resolve this issue by

      1) updating the MaxDB client version to 7.7.07.21 and

      2) Modifying the incorrect entries in table SWFRXIHDR to default correct entries

      Regards,

      Murali Narayanan