Skip to Content
0
Former Member
Jul 19, 2010 at 01:18 PM

CR not displaying certain characters.

18 Views

Afternoon,

I hope this is the best forum for my question/problem otherwise would appreciate a push in the right direction.

Working in Eclipse 3.4.1

Crystal Reports for Eclipse v2.0.4.r825

Oracle9i Enterprise Edition Release 9.2.0.8.0

NLS_Characterset: EE8ISO8859P2

The situation is that I am working with a DB that has Slovakian characters in it.

For example "Hodžovo námestie 3" The ž is not being handled correctly.

If I setup a database connection using the Oracle Thin driver (ojdbc14.jar) I get ? returned on the report in place of the ž or

if I try browse the data by right clicking on the specific column in the "Data" screen, I get a square instead.

If I copy the text into a text box, it can display correctly on the report so this leads me to believe it is not the font settings

that are causing the problems, but rather how the database drivers are interpreting the specific character.

I have tried playing around with the NLS but I have not had too much luck.

The NLS_LANGUAGE item in the registry is "ENGLISH_UNITED KINGDOM.EE8ISO8859P2" so as far as I can tell all enviromental

references to character set are all correctly set to ISO-8859-2.

If I run a SQL query in SLQ*Plus Worksheet, I get the correct string returned : "Hodžovo námestie 3" so I know the data in the

database is stored correctly.

Can anyone give me an idea of what I am doing wrong, what I need to do to solve the problem,

or if you need more info can you tell me what you need and how to get it for you?

Any help would be greatly appriciated.

Cheers

Darren