cancel
Showing results for 
Search instead for 
Did you mean: 

PI 7.1 Naming Convention with Abstract Interfaces

Former Member
0 Kudos

I am using the following naming convention for Service Interface and Operation:

Service Interface: <Business Object><Interaction Activity>_<Out/In/Abs>

Service Operation: <Business Object><Action><Transaction Activity>_<Sync/Async>_<Out/In/Abs>

I have to develop two Interfaces with bpm sync-async bridge and async-sync bridge

1) Sync-async bridge

OUTBOUND: AgencyProcessing_Out.AgencyMaintainNotification_Sync_Out

INBOUND: AgencyProcessing_In.AgencyMaintain_Async_In

ABSTRACT:

AgencyMaintainNotification_Sync_Abs (Service Interface = operation)

AgencyMaintainNotification_Async_Abs (Service Interface = operation)

AgencyMaintainNotificationAck_Async_Abs (Service Interface = operation)

2) Async-sync bridge

OUTBOUND: TrainStatusProcessing_Out.TrainStatusUpdateNotification_Async_Out

INBOUND: TrainStatusProcessing_In.TrainStatusUpdate_Sync_In

ABSTRACT:

TrainStatusUpdate_Sync_Abs (Service Interface = operation)

TrainStatusUpdateRequest_Async_Abs (Service Interface = operation)

TrainStatusUpdateResponse_Async_Abs (Service Interface = operation)

As you can see I was not able to follow the PI naming for Abstract Interface and I decide to choose the name you see above but I am really not sure that this the correct choice. Can you suggest me the names I have to use for my abstract Interfaces?

I was thinking about something likb this for example:

AgencyProcessing_Abs.AgencyMaintainNotification_Sync_Abs

AgencyProcessing_Abs.AgencyMaintainNotification_Async_Abs

AgencyProcessing_Abs.AgencyMaintainNotificationAck_Async_Abs

and

TrainStatusProcessing_Abs.TrainStatusUpdate_Sync_Abs

TrainStatusProcessing_Abs.TrainStatusUpdateRequest_Async_Abs

TrainStatusProcessing_Abs.TrainStatusUpdateResponse_Async_Abs

but when I activate these Service Interface I obtain this error:

"Service interface contains multiple operations whose request messages have the root tag m2:http://MyTest/Antonello/BPM"

I really need your help. I am available for any clarification.

Thanks,

Antonello

Accepted Solutions (1)

Accepted Solutions (1)

former_member200962
Active Contributor
0 Kudos

Are you maintaning more than one Operation (same) names or same message names in one SI? Stefan recently clarified a similar problem:

Regards,

Abhishek.

Former Member
0 Kudos

I read the post. It is not possible to have more operations with the same message within the same Service Interface. For this reason I need to know which names to assign to the Abstract Service Interfaces for BPM bridge sync-async and async-sync, in order to follow the PI 7.1 naming convention.

Antonello

former_member200962
Active Contributor
0 Kudos

Are you trying to have SYNC and ASYNC in the same SI with Req and Resp messages (of ASYNC) referring to the messages of the SYNC flow?

maintain different SI for Async messages.

For this reason I need to know which names to assign to the Abstract Service Interfaces for BPM bridge sync-async and 
async-sync, in order to follow the PI 7.1 naming convention.

Examples are given in this document (page 21 and 22): http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/40a66d0e-fe5e-2c10-8a85-e418b59ab...

Edited by: abhishek salvi on Jul 19, 2010 12:37 PM

Former Member
0 Kudos

I read that document and I try to follow the naming convention but I am not able to use it for abstract interfaces! As I told you before, If I follow the naming convention I have:

AgencyProcessing_Abs.AgencyMaintainNotification_Sync_Abs

AgencyProcessing_Abs.AgencyMaintainNotification_Async_Abs

AgencyProcessing_Abs.AgencyMaintainNotificationAck_Async_Abs

and

TrainStatusProcessing_Abs.TrainStatusUpdate_Sync_Abs

TrainStatusProcessing_Abs.TrainStatusUpdateRequest_Async_Abs

TrainStatusProcessing_Abs.TrainStatusUpdateResponse_Async_Abs

but I can't do in this way because I cannot have operations with the same message within the same Service Interface. So I would need something like this:

AgencyProcessing_Abs.AgencyMaintainNotification_Sync_Abs

AgencyProcessing_Abs2.AgencyMaintainNotification_Async_Abs

AgencyProcessing_Abs2.AgencyMaintainNotificationAck_Async_Abs

and

TrainStatusProcessing_Abs.TrainStatusUpdate_Sync_Abs

TrainStatusProcessing_Abs2.TrainStatusUpdateRequest_Async_Abs

TrainStatusProcessing_Abs2.TrainStatusUpdateResponse_Async_Abs

In this way I would have a differente Service Interface name for Request and Response, but I do not want just add a "2" to make the differente, I want a standard way to proceed. Please help me, suggest me what you would do in my situation.

Thanks,

Antonello

Answers (1)

Answers (1)

Former Member
0 Kudos

Any ideas?