Skip to Content
0

PI 7.31 TLSv1 SSLv2 mismatch

Dec 02, 2016 at 09:48 AM

47

avatar image
Former Member

Hi Experts,

We are facing one issue while we are trying to connect Ariba using middle ware as PI 7.31 single stack. Our request got failed to reach Ariba cloud because of TLS version mismatch. We have analyzed network log and found that when our PI is trying connect or send record to Ariba cloud it is using SSLv2 to say hello to service.ariba.com and it is failing as Ariba only supports TLSv1.

One more thing we have found that when we are trying to manually handshake with Ariba cloud from Server level using command "openssl s_client -connect service.ariba.com:443" it is using TLSv1 only to connect with Ariba and when we trigger record form normal application level (with help of communication channel) it is trying to connect using SSLv2.

Also when we perform manually handshake from server and and it connects to Ariba then after if we trigger records from application level, those records are successfully reaching toPI Ariba cloud for some time (say 1 day). Again after that it starts failing and we have to do at least one time manually handshake again to make it work.

I am unable to understand this behavior. We have checked under JVM parameter and there also TLSv1 is maintained. Is there any other config or solution available for this application level TLSv1 settings?

Please guide and help me as I am newbie to PI.

Appreciate your help and suggestions.

Thank You

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers