Skip to Content
0
Former Member
Jul 08, 2010 at 05:51 AM

AbapTrial7.01 : Cannot run Dispatcher : NSP

28 Views

Hello

after installing AbapTrial7.01 on 32bít Vista and, separately, installing MaxDb, both "Successfully" according to installation messages, I find I cannot start the Dispatcher (starting NSP in sapmmc). Always it stops after 1:15 minutes.

I have found the errror message:

calling db_connect ...

B create_con (con_name=R/3)

B Loading DB library 'C:SAPNSPSYSexe

undbsdbslib.dll' ...

M *** ERROR => DlLoadLib: LoadLibrary(C:SAPNSPSYSexe

undbsdbslib.dll) Error 126

M Error 126 = "Das angegebene Modul wurde nicht gefunden."

B *** ERROR => Couldn't load library 'C:SAPNSPSYSexe

undbsdbslib.dll'

in the file dev_w0 under C:SAPNSPDVEBMGS00work.

However, C:SAPNSPSYSexe

un does indeed contain dbsdbslib.dll.

C:usr is empty.

Looking at Jonathan Mejia's post in I wonder if the problem might be in the download from http://www.sdn.sap.com/irj/scn/nw-downloads.

He speaks of MAXDB files in the installation directory and my installation directory does not have them.

He has

<installer_directory>SAPNWABAP701SR1_TRIALMaxDB_77_SP6_Build07_RDBMSDATA_UNITSMAXDB_WINDOWS_I386

and I have no MaxDB files in my downloaded

SAPNW7.01ABAPTrial

.

The download was difficult: dozens of times it broke off with scnsorry and only after writing to sdn@sap.com was I able to download. Now, again, I cannot download even after writing to sdn.

Are the download files complete?

(New post replacing since neiterh edit nor reply to old post are permitted).

Message Server connection:

If I say in dbmcli "db_state" I get ONLINE, and if I then say "stop" I see OK and then if I start NSP in sapmmc the Dispatcher goes to state

Running, Message Server connection OK

with green icon until 1:10 minutes and then stops at 1:15.

Edit: when I run

c:sap

spsysexe

un

3trans -d

I get a popup saying that I need

libSQLDBC76.dll

but this is nowhere in the files I downloaded from sdn (SAPNW7.01ABAPTrial from http://www.sdn.sap.com/irj/scn/nw-downloads).

Where do I get this file?

Edit

it seems that Jonathan Mejias installation and my simple AbapTrial download are different animals.

I was able to find the file he mentioned in another download.

I put it into C:SAPNSPSYSexe

un.

I ran r3trans -d again and in the trans log I see

4 ETW000 create_con (con_name=R/3) 0 0.000000

4 ETW000 Loading DB library 'dbsdbslib.dll' ... 0 0.000000

4 ETW000 load shared library (dbsdbslib.dll), hdl 0, addr 10DB0000

4 ETW000 8795 0.008795

4 ETW000 using "C:SAPNSPSYSexe

undbsdbslib.dll"

4 ETW000 60 0.008855

4 ETW000 Library 'dbsdbslib.dll' loaded 33 0.008888

4 ETW000 function DbSlExpFuns loaded from library dbsdbslib.dll

4

and so the file was found and loaded this time.

Even dev_wo seems happy;

B create_con (con_name=R/3)

B Loading DB library 'C:SAPNSPSYSexe

undbsdbslib.dll' ...

B Library 'C:SAPNSPSYSexe

undbsdbslib.dll' loaded

B Version of 'C:SAPNSPSYSexe

undbsdbslib.dll' is "700.08", patchlevel (0.7)

B New connection 0 created

M sysno 00

M sid NSP

However the Dispatcher stops as before.