Skip to Content
0
Former Member
Jul 07, 2010 at 12:19 PM

Select is not selecting

19 Views

i have written a select statement that although the table is populated with values, it is not selecting the records based upon the field i have specificed.

TYPES: BEGIN OF measure_docs,
        ref_obj TYPE imrc_mdocm,
        nodeid     TYPE diohfw_nodeid,
  END OF measure_docs.

        SELECT ref_obj nodeid FROM diohfw_nodes INTO TABLE gt_measure_docs
          FOR ALL ENTRIES IN gt_diohfw_nodes
          WHERE sup_nodeid = gt_diohfw_nodes-nodeid
          AND   type       = 'MDC'.
     

      IF NOT gt_measure_docs IS INITIAL.
        SELECT * FROM imrg INTO TABLE gt_imrg
          FOR ALL ENTRIES IN gt_measure_docs
          WHERE mdocm = lt_measure_docs-ref_obj.

      ENDIF.

i have 15 entries in my gt_measure_docs table... i can copy the paste into se11 IMRG and see the values in the data display.

the field mdocm has an ALPHA conversion on so i tried adding the 00000000000000000234 to convert to 234, but it still cannot find the entries... i am sure i have missed something simple....

i typed the "ref_obj" as imrc_mdocm but still no dice! :o( any ideas what i have missed?