Skip to Content
avatar image
Former Member

Wily Introscope agent configuration

Hi,

If one of you can help me with some advices about how to configure Wily Agent on my Solution Manager.

First I want to let you know all steps that I performed until now:

1. Configuring SM (Solution Manager) using TX Solman_setup

2. Using [Wily Introscope Guide|https://websmp105.sap-ag.de/~sapdownload/011000358700001995842008] I performed the followings steps:

2.1. Installed Wily Enterprise Manager, started and this working fine (I am able to connect using Wily Workstation) on SM

2.2. On SM (the same host as Wily Enterprise Manager) I performed the following steps in order to install Wily agent

2.2.1. First I tried to install this agent using automatic method:

a. Enabled Maintenance Mode on SMD from TX solman_workcenter >Overview >Common Tasks >Agent Administration >and here I checked the radio button Maintenance Mode

b. Deployed ISAGENTSMD801_01-10007435.SCA using SDM (/usr/sap/ZSP/DVEBMGS00/SDM/program/RemoteGui.sh)

c. Disable Maintenance Mode on SMD.

d. According to Wily Introscope Guide at page 19 when I try to go to Diagnostics Setup Managed Systems

Introscope Agent here I am not able to see the agent running. In my case the agent has the red flag (SMD agent is not running).

e. Ca you tell me what if there I have to do another configuration than the steps listed in Wily Introscope Guide?

I think my Wily Introscope agent in not running, but I don't know exactly what I have to to to start up this agent.

f. Can you please tell me the difference between SMD agent and Wily agent?

2.2.2. If the above automatic SMD installation was not working I tried the manual installation listed at page 21.

a.I extracted the ISAGENTSTD02_0-10007435.SAR to /usr/sap/ccms

b.I changet the following in /usr/sap/ccms/wily/IntroscopeAgent.profile

introscope.agent.enterprisemanager.transport.tcp.host.DEFAULT=my IP address

introscope.agent.agentNameSystemPropertyKey=ZSP_Wily_Agent

c. I configured the JVM AutoProbe.

Because my JAVA is IBM Java VM 1.4.2 (SR1x) x86_64 I followed the note 1149214 to create Create AutoProbe Connector, and after that I added the following JAVA parameters using configtool in: cluster-data >Instance_ID42052 >server_ID42052 >General (tab) >Java Parameters

-Xbootclasspath/p:/usr/sap/ccms/wily/connectors/connector.jar:/usr/sap/ccms/wily/Agent.jar

-Dcom.wily.introscope.agentProfile=/usr/sap/ccms/wily/IntroscopeAgent.profile

-Dcom.wily.introscope.agent.agentName=ZSP_Wily_Agent

-Dcom.wily.autoprobe.prependToJVMRuntimePath=/usr/lib64/jvm/java/jre/bin/j9vm/jclSC14/classes.zip

d. After I added the bellow parameters and restarted the JAVA stack using TX SMICM >Administration >J2EE Instance local > Send Soft Shutdown >With Restart my JAVA engine didn't started, but if I will remove the above parameters the JAVA engine start up fine.

Can you please correct if I am wrong in my above steps that I performed in order to install and configure WIily Introscope Agent on my Solution Manager host. And can you please give me the complete steps that I have to do in order to have this agent running fine?

Thank you,

best regards,

Florin Radulea

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jul 15, 2010 at 11:09 PM

    Dear Florin ,

    Your question: Can you tell me what if there I have to do another configuration than the steps listed in Wily Introscope Guide? I think my Wily Introscope agent in not running, but I don't know exactly what I have to to to start up this agent.

    The Introscope Agent is started with the Java Stack (J2EE).

    Your question: Can you please tell me the difference between SMD agent and Wily agent?

    Managed system runs the SMD Agent and/or Introscope Bytecode Agent , this two report to Wly Introscope EM.

    Solution Manager Java grabs information from Wily Introscope EM for Java Data, and from the SMD Agent for ABAP data.

    Solution Manager Java has the extractors and runs all extraction processes.

    Solution Manager ABAP runs EFWK, BI and SERVICE SESSIONS.

    Please check page 4 of the attachment contained in SAP note 1332428. I like to use this image to illustrate this.

    My remarks: What might be causing your issue

    Your steps seem to be fine. However, if your system is 7.10:

    -


    The introscope setup will NOT work for 7.10 systems. It works

    for 7.0x and for 7.11+ but not for 7.10, because of the APIs available

    with the 7.10 J2EE engine.

    Therefore, you should completely disregard this error. and you should

    only use the introscope setup wizard to get the parameters to copy

    and paste into your configtool.

    -


    My recommendations

    I recommend you to remove the parameters and deploy the Introscope Agent using SDM, following the Introscope Version 8

    Installation Guide For SAP.

    Best regards,

    Guilherme Balbinot

    Edited by: Guilherme Balbinot on Jul 16, 2010 1:09 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Kiran,

      You have to install SMD agents (epa agents are obsolete) on physical host from OS level...

      For Java systems, ISAGENTxx agents as a part of LM-SERVICE and those introscope agents will be installed through solman configuration http://<server>:<port>/smd/ -> managed systems -> Introscope agent..

      Note : for 7.1x systems, after installing java introscope agents, you need to manually update the config tool..

      Updating the VM Parameter is not supported on systems running SAPJ2EE 7.10. Please enable the VM parameters and check SAP Note 797147..

      Regards

      Suresh