Skip to Content

XSLT 2.0 in PI 7.31 with saxon9 processor gives java mapping error

I followed the instructions in 1893110 - Integrate external XSLT trannsformer in PI Mapping Runtime trying to use an XSLT 2.0 mapping in a PI 7.31 system (SP17). I've tried the latest Saxon 9 versions (from 9.5), but all are giving the same error:

"Transformer Configuration Exception occurred when loading XSLT ***.xsl; details: java.lang.ClassNotFoundException: ResourceException during loading class com.sap.aii.mapping.xslt.saxon.JavaExtensions$JavaFunctionLibrary"

The operation mapping I am trying to test includes a java mapping as the first step, the xlst mapping as step 2, and a message mapping as step 3. I also tried without the java mapping, but the error was the same.

I tried to apply the following note manually - 2221350 - Support for Java Extensions in the SaxonHE XSLT Transformer, but I'm unable to activate the attached java code under Attributes and Methods.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

0 Answers