Skip to Content

HANA not starting after host rename.

Hello Experts,

I have renamed my HANA host to a new name. (I can ping it, and maintained in the /etc/hosts)

Has anyone faced issue when after the rename, HANA does not comes up, the nameserver has the below error log:

-------

unclean shutdown of service instance with pid 258840
service startup...
accepting requests at 127.0.0.1:30101
searching for master nameserver sapsidhdb:30101 ...
assign as master nameserver. assign to volume 1 started
Checking for recovery request ...
Loading topology ...
Opening persistence ...
run as transaction master

Couldn't find own nameserver in topology (sapsidhdb:30101)
-> stopping instance ...
prepare for shutting service down...
stop ClockMonitor thread...
stop MasterTokenLockWriter /usr/sap/SID/SYS/global//hdb/nameserver.lck thread...
setInactive(nameserver@sapsidhdb:30101)
---------------------------/etc/hosts file have been maintained.All profile parameters checked, looks fine.I have no idea why this error out:--------------

StartService
Impromptu CCC initialization by 'rscpCInit'.
See SAP note 1266393.
OK
OK
Starting instance using: /usr/sap/SID/SYS/exe/hdb/sapcontrol -prot NI_HTTP -nr 00 -function StartWait

Start
OK


StartWait
FAIL: process hdbdaemon HDB Daemon not running

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Feb 06 at 11:43 AM

    Hello Harikrishna,

    You should have checked the note

    2550327 - How-To Rename an SAP HANA System

    Regards,

    Yuksel AKCINAR

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Yuksel, I referred the same note while rename.

      So, just that everyone knows, I could not fix this so I had to do a reinstall HANA and then recover it from the backup.

      If anyone has a fix, please update us here.

      Thanks.