Skip to Content
avatar image
Former Member

How to activating Widgets in B1 Cockpit

Dear All,

I would like to know that has anyone have experiment in SAP Business One PL12 Cockpit feature? I need help in setting up B1i Server Address for Dashboard's Widgets.

Thank you in advance.

Nghia

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 15, 2010 at 04:12 PM

    I've installed sap 8.8 PL12 and afterwards the SAP Integration Solution for B1

    Folowed everystep, tested the connections in SDL, everything OK, url in cockpit configuration is correct. But I keep getting the folowing error in the dashboard widget:

    404-Not Found

    Internal Reason

    /com.sap.b1.dashboards/001sap0001.SAP_Dashboard_001.DAB003/default.html

    I've tried as mentioned in this thread to deactivate it and reactivate again several times, it doesn't go away.

    Do I need Xcelcius for the dashboards to work? (I starting to get lost here.., )

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I'm using SQL Server 2008 default instance, all licenses ok.

      But.. finally solved! De-activated not only the widgets, but all cockpit, restarted every services, and reactivated cockpit.... SOLVED! finnaly! Hopefully it won't happen again later in the production enviroment 😊

  • avatar image
    Former Member
    Jul 07, 2010 at 10:01 PM

    I have installed it but i get this error:

    SAP B1iP detected an error:

    Emitted HTTP-Code

    403 - Forbidden

    Internal Reason

    XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

    Recommendation

    Check for the correctness of your activity or environment or ask your system-administrator for further help.

    -


    Full Internal Error Message

    XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear Janos,

      i have already installed 9.1 do i have to reinstall it or is there any other way out?

      kindly suggest me...

      Regards,

      Usman

  • avatar image
    Former Member
    Nov 30, 2010 at 06:48 AM

    Hi All

    I have followed all the steps in the post and I get a message now that says The widget is loading or currently not available.

    Any ideas

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 06, 2010 at 12:42 PM

    Good question.

    There isn't too much documentation at the moment.

    See here: LINK[https://service.sap.com/sap/support/notes/0001471016?nlang=E]

    What I did was set the value of the B1i Server address to be the local PC name.

    On startup there is an error stating that the server address is incorrect, but the Widgets work.

    What I think is missing is that you can't share the widgets.

    Oh, the Service Call dashboard (which I think is flash based and may need Xcelcius) doesn't work.

    Edited by: John-Paul Della Puta on Jul 6, 2010 2:43 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello All,

      So basically if you read the document described in the note, you can set up the cockpit, the personal work center.

      To turn on the dashboards, no problem:

      In the documentation another docu is referenced, SAP B1 8.8 integration installation and setup giude (working with dashboards section)

      to download the integration, navigate to than download the B1I

      (Updates" SAP Business One 8.8" B1 8.8 INTEGRATION COMPONENT)

      in this package you can find the Working_with_Dashboards_in_the_Integration_Component_HU.pdf documentaion in Hungarian language 😊 and of course in english. Also find xcelsius files there which are working...

      Regards

      János

      Edited by: János Nagy on Jul 6, 2010 7:40 PM

      Edited by: János Nagy on Jul 6, 2010 7:40 PM

  • Jul 09, 2010 at 04:34 PM

    I think I'm at the Same point you are at with the Widgets.

    But what I found is that the DI Proxy Service and the EventSender Service - won't run.

    If I run the run.bat file in the DI Proxy folder - it will run and the B1iP SID can connect to it.

    This is what I'm seeing in the DI Proxy log:

    ERROR: 10:04:52: Load the JVM DLL failed

    ERROR: 10:04:52: Load JVM dll failed

    I'm sure I have the right JVM version 5.0, I've also tried 6.1 with no luck.

    Any one else able to get past this?

    Add comment
    10|10000 characters needed characters exceeded

    • I was able to get past this. I had the right JVM installed, but during the setup I needed to select "Java\jdk1.5.0_22" instead of "java\jre1.5.0_22". The Widgets worked after that.

  • avatar image
    Former Member
    Jul 14, 2010 at 12:03 PM

    Dear All,

    i got a similar problem.

    Insallation worked, no errors were displayed but when i want to display the Dashboard Widget following message appears:

    SAP B1iP detected an error:

    Emitted HTTP-Code

    404-Not Found

    Internal Reason

    /com.sap.b1.dashboards/001sap0001.SAP_Dashboard_001.DAB003/default.html [err004]

    all Services run

    if i check http://localhost:8080 tomcat is also running

    where is the mistake ?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 22, 2010 at 03:33 PM

    Hi all,

    After installing the cockpit, i've got error 401 not authorized, checking into documentation there's the info:

    "If the B1i password is not correct or licenses are not properly assigned to this user, the error 401 not authorized will be displayed in the Dashboard widgets.

    To fix this, correct the B1i user password in the SLD (system landscape directory) within the Integration Framework and ensure licenses are assigned as specified in section Licenses in this document."

    Then i've tried to go in Start > All Programs > Integration Solution for SAP Business One > Integration Framework and got the following message.

    "SAP B1iP detected an error:

    Emitted HTTP-Code

    403 - Forbidden

    Internal Reason

    XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

    Recommendation

    Check for the correctness of your activity or environment or ask your system-administrator for further help."

    Checking this thread, i've changed the file Xcellerator.cfg located on C:\Program Files (x86)\SAP\SAP Business One Integration\B1iServer\tomcat\webapps\B1iXcellerator from "xcl.http.localOnly=true" to "xcl.http.localOnly=false" and still got the same message.

    I'm running SAP Business One 8.8 PL 12 on MSSQL 2008 with default instance, i've already checked B1i licenses and even tried to turn off cockpit and turn on again...

    Someone can help me?

    Thanks.

    Lucas Sigaki

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I´m like Mike Nielsen

      10. Check if the scenario exists in the BizStore

       Open the B1iP Control Center -> Maintenance u2013> BizStore Download -> BizStore url click u2026

       In the Choose dataset check if com.sap.b1.dashboards appears in the list

      Any idea of what to do.

      In this case the cliente connect with the iPhone, with de iPad can´t connect.

      But the cockpit it´s always with the error:

      SAP B1iP detected an error:

      Emitted HTTP-Code

      404 - Not Found

      Internal Reason

      /com.spa.b1.dashboards/001sap0001.SAP_DASHBOARD_001.DAB003/default.html

      I´ve tried to desinstall all the components, Flash, Java, Integration Component and Reinstall all the system.

      The WSMobile is working, is the cockpit that never works.

      Server: 2003 Server

      SQL: SQL2005 Standar (With rigth collation)

      SAPB1: 8.8 SP00 PL19

      Int. Component: 1.0 PL02