Skip to Content
0
Feb 05, 2019 at 04:14 PM

Difficulties installing the XSA client in my mac laptop

211 Views

Hello,

I'm trying unsuccessfully to install the XS client in my mac laptop, I already downloaded and unzipped clients_mac's directories HDB_CLIENT_MACOS and xs.onpremise.runtime.client_darwinintel64. Also executed sudo ./hdbinst and the installation process was (partially successfully) executed.

When executing sdbrun from the applications launchpad the following error is generated:

Dyld Error Message: Library not loaded: libsdbrun.dylib Referenced from: /Applications/sap/*/sdbrun.app/Contents/MacOS/sdbrun Reason: image not found. error-sdbrun.png

I found that the library libsdbrun.dylib is located under a subdirectory of the directory xs.onpremise.runtime.client_darwinintel64 in following path:

xs.onpremise.runtime.client_darwinintel64 --> sapjvm_8_jre --> lib --> server

However, as I dont know where in my mac directories I must locate the directory xs.onpremise.runtime.client_darwinintel64 the system cannot find it.

I don't know what to do and where install the content of xs.onpremise.runtime.client_darwinintel64, probably installing correctly this part of the installation download the error could be solved.

After that, it is no clear for me which is the command for executing the XSA from the browser, in the guide manual, it is no clear how to do it, which one is the command to execute it? for test the XS I execute xs or xs or xs app and nothing happens.

In the other hand, I already successfully generated a HaNA express virtual machine in my mac with by using Virtual Box. As I only have 8 gb of ram I installed the basic version of it. It works fine so far. Each time I run the virtual machine a IP address is generated, it is posible access the server but I dont know how access it by using the XSA client.

Thank you a lot for your support.

Regards, Alex.

Attachments

error-sdbrun.png (141.3 kB)