Skip to Content
author's profile photo Former Member
Former Member

JSPM gives JRE error during Update of CE 7.11 to CE 7.2

Hello Gurus,

I downloaded the SPS files for CE 7.2 update from CE 7.11 SPS4.

I started the update using CEUpdateManager. After some time, the update failed and after that when I try to run it again, it fails to login to JSPM and I understand from JSPM logs that JSPM is looking for JRE 1.6.0 or higher, whereas CE 7.11 has JVM 5 which corresponds to JRE 1.5.

The thing is, CE 7.11 and CE 7.2 systems do not need separate JDK/JRE installations as they use these from SAPJVM. But during my upgrade, JSPM has got updated to 7.20 whereas the rest of the components did not and that is where update failed. So now, even if I try to run JSPM, it does not start and only gives the following error message at the command prompt:

Updating JSPM content...

Updating local copy of SAP JVM ...

Execution failed: Java Runtime version 1.5.0_17 detected. JSPM requires Java Run

time 1.6.0 or later to run. Java Runtime version 1.5.0_17 detected. JSP

M requires Java Runtime 1.6.0 or later to run.




In JSPM.LOG file, I can see:

Error]: Java Runtime version 1.5.0_17 detected. JSPM requires Java Runtime 1.6.0 or later to run.

I tried to manually patch JVM to 6 level using note 1025085 and tried bootstrapping as well using note 710663 but none of these worked and upon restarting the system, still SAPJVM 5 is getting copied by sapcpe.

Please suggest how exactly should I solve the problem of JSPM needing jre 1.6.0 while SAPJVM providing 1.5. I am pretty sure that installing JRE 1.6.0 on my machine will not help in CE systems and still I have tried that but to no help.

Please help.



Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jul 01, 2010 at 07:54 AM

    Hi Shitij

    Once you installed the JDK6 in the system, you need to update the JAVA_HOME Enviromental variable in the My computer properties. JSPM will recognize from JAVA_HOME Enviromental variable.

    Hope it will helps



    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Mahesh,

      I had already downloaded SAPJVM 6 as well. My stack queue was fine.

      But, now my issue is solved. It turns out the CEUPDATEMANAGER file that we were using earlier, was still for 7.11 only, whereas we had to use the one from 7.20. We did not realize this mistake because the stack files had been downloaded almost a month ago.

      We have now downloaded the 7.20 CEUPDATEMANAGER SAR file and the upgrade worked smoothly.



Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.