Skip to Content
avatar image
Former Member

Automatic Deployment not working on Activation

Hi Experts,

I am using CE 7.1 developer studio, and NWDI set up.

Please see the steps that i have mentioned below...

I have a track which is containing a single DC of type WebDynpro, This DC is containing one view with a textView UI element with the text property "Hello World"

I have followed the below sequence of steps...

1) Import the development confuguration (Track) from the SLD into developer studio using the User ID1. (This ID has NWDI.Administrator UME Role assigned, as well as Administrator UME role assigned.)

2) Sync / Create Project (This will create a project structure and get the Inactive source from the DTR to my Local Machine)

3) goto the webdynpro perspective edit the view and change the text property to "Hello World has Change...!"

4) the above step will result in Creation of an activity.

5) Now I Save the changes and build the DC. (Please note that I have just built the DC, not deployed it).

6) From the Development Infrastructure Perspective Checkin the activity that was created from "Open Activities" view.

7) From the "Activation View" activate the activity that was "checked in" as mentioned in the previous step.

8) Activation process gets completed successfully.

Now Ideally, if I run the application it should reflect the last modified changes.

that is it should show "Hello world has changed",

But unfortunately it's not, it is showing the non modified version "Hello World"

According to standard NWDI activation process...

when the changes are activited...following sequence of steps are carried out.

1) Store the Sources into "Inactive Workspace" in DTR.

2) DTR Sends build request to CBS.

3) CBS will collect new objects from Inactive workspace as well as existing objects from Active workspace and builds the Sources.

4) After the build is successful, CBS will deploy the archives to central J2EE system, and store the sources in Active Workspace.

Additional Information: Now if delete the track and load the same track again,

it brings the correct modified source code with "Hello world has changed...!"

In both sycn Active Source and Sync Inactive Sources

This means that modified sources are getting checked in properly into both the Active and Iactive workspace but not getting deployed on activation.

Please someone help me understand why automatic deployment is not working on Activation?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jun 29, 2010 at 04:22 PM

    Hi Shreyas,

    Is there any chance that the box for "Disable automatic deployment" of your track is checked?

    Dao

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 29, 2010 at 02:51 PM

    Hi there,

    deployment in DEV and CONS works asynchronous. this means a request is not immediately deployed after the request is build. A successful build can although mean that there was a deployment error. So sometimes you jsut have to wait a couple of minutes for your changes to be deployed.

    When creating a track or deleting a runtimesystem and reconfiguring it. NWDI tries to sync the track and the runtimesystem immediately.

    So I would suggest to check this as follows:

    - After the request finished successfully in CBS open CMS Gui and navigate to the DEV tier of your track in transport studio.

    - there is a button "deployment" (second from the right) hit it...

    - a window with the deployment details of the tier will open. here you can see if a queue is still pending. you can check when the DC was deployed last time. and you can initiate a deployment of the queue here to. But this will not always lead to a immediate deployment.

    - Here you can check if there have been deployment erros (rc >4)

    So here you can get some clues on what is going on. Usually deployment fails because NWDI cannot reach the runtime system or the user/password is wrong. Yo can check if the system is accessible by nwdi by getting the dubstitotion parameters of the system. You can find the line: View/Edit Deployment Substitution Variables at he bottom of every systems overview. At the right of this line is a button. if you press it and some variables should be shown. Nwdi can access your system for deployment. If not in the upper left an error message will be shown.

    Let us know what your results are

    Have a good time

    Jan

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 02, 2010 at 03:53 PM

    Hi Jan Benkert & Dao Ha,

    Thank you so much for your guidence,

    It was a very foolish mistake from my side, I had configured everything correctly in RunTime Systems for Development System except the Deploy controller Port Number, which was wrong. So only on activation, my changes were not getting deployed, I changed the port to the correct port number. And bingo..! the problem was solved..! now on activation my changes are getting deployed too...!

    Regards,

    Shreyas Pandya

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Shreyas,

      I'd expect you to get some kind of errors in the cases of incorrect deploy host/port/pwd 😊

      Anyway, glad that you were able to solve your problem.

      Cheers,

      Dao