Skip to Content
0
Former Member
Jun 29, 2010 at 08:45 AM

Error connecting to HTTP system

237 Views

i am working on an HTTP scenario (although not sure if SOAP would work as an alternative)...

anyway, when i try and connect to the server, i get the following message in my SM59 connection...

Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.


Hint: https://host.domain.com/


--------------------------------------------------------------------------------

Apache Server at host.domain.com Port 443

when i spoke with the third party host, they have an unsigned certificate on the server...

they also provided me with this...

Can I suggest that you send the HTTP request in what is called, in the curl documentation, "insecure" mode, for our stage environment. Here's what the curl docs say about "insecure":

This option explicitly allows curl to perform "insecure" SSL connections and transfers. All SSL connections are attempted to be made secure by using the CA certificate bundle installed by default. This makes all connections considered "insecure" to fail unless -k/--insecure is used.

See this online resource for further details: http://curl.haxx.se/docs/sslcerts.html

I hope that you'll find that whatever package you're using to make the HTTP connection will give you the option of specifying an 'insecure' connection.

can i use "curl" with http or even soap from PI? i chose HTTP as i have to send a Key as a Header field with the connection... is this something that can be done?

as an after thought, if i connect on port 80, i get the following error: ICM_HTTP_SSL_ERROR