Skip to Content
avatar image
Former Member

ASP.NET Program runs slow, uses IIS instead of Report Server

Hi,

I have an ASP.NET program (Visual Basic.net 2008) that has an embedded Crystal Report (Full V12.2.0.290) and it runs against a large database on my old test server running Windows 2003 (32 Bit) machine in 10 seconds. On my new Production machine with 64 bit Windows 2003 & SQL Server, the same report takes 65 seconds. I have setup a virtual directory for my website and a virtual directory for each report in IIS. I am already using a SQL view in Crystal which significantly sped things up. I have noticed that when I run the SQL Profiler, the test server shows the 'Application Name' as 'Report Server' and on the Production machine it returns IIS as the 'Application Name'. I am running IIS V6.0 and ASP V2.0.50727 (32 bit on both machines). Can anyone please tell me what I may do in order to get my production machine configured correctly.

Thanks!!!,

Glenn

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jun 28, 2010 at 12:57 PM

    Moved to .NET SDK forum

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 02, 2010 at 08:58 PM

    Not sure what SQL Profiler is trying to show there. What do you see as the process when you use something like [Modules|https://smpdl.sap-ag.de/~sapidp/012002523100006252802008E/modules.zip] or [Process Monitor|http://technet.microsoft.com/en-ca/sysinternals/bb896645.aspx]?

    Ludek

    Follow us on Twitter http://twitter.com/SAPCRNetSup

    Add comment
    10|10000 characters needed characters exceeded