Skip to Content
1
Feb 03, 2019 at 08:30 PM

HANA XSA + node.js 6.11.* support for ES6

290 Views

Hello,

I have HANA XSA instance with node.js version 6.11.* and according to node,green it should support many features of ES6, including spread operators. I have enabled es6 in eslint environment in Web IDE for HANA, however deployment to XSA always fails and the syntax error points to a spread operator. The thing is that the error occurs in some module downloaded from npm, so clearing ES6 syntax is not an option.

Is there any other configuration point? Or in practice ES6 is not supported?