Skip to Content
avatar image
Former Member

Strange Crystal Reports error

We have a setup in our production environment where the IdM database and the IdM runtime components reside on different servers. In our test environment the database and the runtime components exist on the same server. We have created two reports and they work fine in development and in test, but in production we get the following error:

Failed generating report Report-58698.pdf

com.crystaldecisions.sdk.occa.report.lib.ReportSDKException: Error loading database connector. The class 'com.crystaldecisions.reports.queryengine.driverImpl.DriverLoader' could not be accessed.---- Error code:-2147467259 Error code name:failed

putNextEntry failed storing51221

Initially I thought that maybe the JDBC connection on the reporting repository was setup incorrectly as it pointed to localhost. That however has been changed, so that it now points to the database server, but the error is still the same???

I've checked all the Crystal Reports jar files in the different environments. I've checked the class path extension in the Identity Center console, but everything seems to be ok.

Any ideas?

./Anders

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jun 25, 2010 at 08:11 AM

    Hello again,

    It turns out that it was the repository constants for the reporting repository that were incorrectly setup. After changing the pointer in DATASOURCE to point to the correct database and typing in the password for the mxmc_rt user again, suddenly everything worked.

    Best regards,

    Anders

    Add comment
    10|10000 characters needed characters exceeded