Skip to Content
avatar image
Former Member

MaxDB install on Ubnutu 10.04 Lucid

Greetings, I am installing MaxDB on a fresh install of Ubuntu 10.04. The install is failing in the initial stages when it fails to find libstdc+.so.5. Ubuntu 10.04 supports libstdc.so.6 and I verified it is installed. However, the MaxDB install will not complete without finding libstdc+.so.5. has anyone come across this and what did you do to overcome the issue?

TIA,

Pat

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jun 24, 2010 at 06:10 AM

    Just create a symlink from your libstdc+.so.6 library to libstdc+.so.5, it should still work.

    Eg.

    cd /usr/lib

    ln -s libstdc+.so.6.0.13 libstdc+.so.5

    Nelis

    Add comment
    10|10000 characters needed characters exceeded

    • cannot load wxWidgets properly: Can't load './Wx.so' for module Wx: libpng.so.3: wrong ELF class: ELFCLASS32 at DynaLoader.pm line 230.

      at SDB::Common::Require line 113

      You've linked libpng.so.3 to a 32 bit library it should be 64 bit for maxdb-all-linux-64bit-x86_64-7_7_07_16

      root@centaur:/lib64# file libpng12.so.0.42.0
      libpng12.so.0.42.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
      root@centaur:/lib64# ln -s libpng12.so.0.42.0 libpng.so.3
      

      Nelis

  • avatar image
    Former Member
    Mar 23, 2011 at 07:42 PM

    I had this problem as well:

    cannot load wxWidgets properly: Can't load './Wx.so' for module Wx: libtiff.so.3: cannot open shared object file: No such file or directory at DynaLoader.pm line 230.

    at SDB::Common::Require line 51

    Tried to link the files as suggested:

    ln -sf /usr/lib/libtiff.so.4 /usr/lib/libtiff.so3

    LOOK CLOSELY.... the missing file is 'libtiff.so.3' and the linking file is 'libtiff.so3'

    I did not have the file ' /usr/lib/libtiff.so.3' (causing the error) So I copied the file ' /usr/lib/libtiff.so3' and renamed it to ' /usr/lib/libtiff.so.3'

    cp /usr/lib/libtiff.so3 /usr/lib/libtiff.so.3

    Then linked the correct file:

    sudo ln -sf /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3

    FIXED! Was able to run the ./SDBSETUP without errors.

    Hope this helps someone.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I think you are all riht, but on Ubuntu 13.X the libs: png and tiff are not in /usr/lib, they are in /usr/lib/i386/linux/gnu/lib*

      so symlinking to the correct files(alt. search with find)

      should help you.

      regards

      sebastiano