Skip to Content
avatar image
Former Member

Import large data files into Fact Table

Hi,

I need to import 60MB file into my Application. I tried import into Fact Table as Import didn't work. Even with that I am getting the Overflow error. I tried splitting the file into 2 and later into 4. Let me know of any other suggestions as I dont want to split my file into 10 files..

Thanks

Raj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jun 24, 2010 at 04:36 AM

    Hi,

    You can increase the COMMITTIMEOUT in "Set AppSet parameter" some higher number. By default its set to 9000 secs. If the inset is more than this then it fails. Its just a parameter to increase the perfomance.

    Hope it helps

    Raman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 24, 2010 at 06:10 AM

    Hi Raj,

    If this is a one time activity, then you can try to load the file directly into the fact file in SQL using the import functionality of SQL.

    Hope this helps.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you Radharaman and Nilanajan. It's working fine when I run the Import into Fact table with No for "run default Logic" and "run process cube". Do you have any idea on why it's behaving like this?