Skip to Content
avatar image
Former Member

CR XI R2 Merge Modules won't upgrade properly to target machine

I have a VB6 application that uses Crystal Reports RDC to imbed reports and viewer. I am now trying to upgrade from Crystal Reports XI R1 to R2. I have the full Crystal Reports R2 SP6 installed with the new CRviewer in the application. I have no problems whatsoever on my development machine, either in development mode or using the compiled EXE.

I have downloaded the four SP6 RDC Merge Modules (11.5.12.1838) to imbed into my install package which, after some initial trouble, now releases all to their proper location (\Program Files\Business Objects\Common\3.5\...) on the target machine. About four DLLs wonu2019t register properly, either as the merge module is installed on the target or even when I try to register them manually. Using regsvr32, I get the error: LoadLibrary (u201Ccrqe.dllu201D) failed u2013 The specified module could not be found. u2013 even though the DLL is right there in the folder that the merge module dumped it into.

When I attempt to launch the CRviewer within my application, I get a run-time error u201815003u2019 (application-defined or object-defined error) and the application aborts, closing the task.

The merge module CR files originally released in R1 to the target machine are located under a different folder structure (\Program Files\Common\Business Objects\3.0\...) and are not removed with the R2 merge modules. Some thought as to whether there is a conflict and my application is having conflict with the old R1 modules even though it is looking for the R2 DLLS under the same name.

Is there a way to remove the files associated with the original R1 merge modules?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jun 24, 2010 at 02:34 PM

    Couple of things.

    Theoretically, XI r1 and XI r2 can be installed on the same box. My experience tells me to not do that. So removing the CR XI r1 install before installing CR XI r2 is recommended. And no, the CR XI R2 msm files will not remove XI r1 runtime. You will have to do this your self.

    If after you have only CR XI r2 on that box and you still have similar issues, use the [Modules|https://smpdl.sap-ag.de/~sapidp/012002523100006252802008E/modules.zip] utility to find out what dependency is missing and thus preventing the dlls from registering.

    Ludek

    Follow us on Twitter http://twitter.com/SAPCRNetSup

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ludek Uher

      Well, I tried the various suggestions (the RDC merge modules don't show up in Add-Remove as an installation package but are instead tied to my application itself as features) but the only way I can get the installation to work is to completely remove my application package (with the old CR XI R1 DLLs) and then completely re-install it with the new R2 RDC merge modules.

      I tried to remove the old Business Objects 3.0 Common folder structure but nothing short of removing my package completely and re-installing it (versus upgrading it) with the new Business Objects 3.5 folder structure would work. I wish that the same folder structure had been retained and then replacing the DLLs in place might have been a more straight-forward approach... but that was not how it was done, so I'll live with it.

      Thanks for your help anyway.

  • avatar image
    Former Member
    Jun 26, 2010 at 12:51 AM

    Couldn't get it properly upgrade short of completely removing my application with the CR XI R1 RDC merge modules and then re-installing the application with the R2 RDC merge modules.

    Add comment
    10|10000 characters needed characters exceeded