Skip to Content
avatar image
Former Member

Debug between 2 WD

Hi All - I have 2 WD components from WD1 I'm clicking a button that will open WD2, I have breakpoints (BPs) in WD1 at the time of calling WD2 and I also have breakpoints (BPs) in WD2 WDDOINIT method. I activated my BPs in Tcode SRDEBUG.

The code is hitting BPs of WD1 but when is calling WD2 BPs it don't stop. I wanted to verify that the code is actually trig-erring WDDOINIT of WD2 and I commented out code to test and its actually going in the code since data is not binding when I comment out the binding.

let's say that I copy/paste the code from WDDOININT and put it in an ACTION, once the user is in WD2 and click the action then BPs will stop in WD2, why BPs do not stop in WDDOINIT during initialization?

Does anyone knows another way to stop BPs when 2 WD are involve.

thanks!

Jason PV

Edited by: JperezVelez on Jun 22, 2010 4:28 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 22, 2010 at 11:45 AM

    HI ,

    You can set the BP by using the key word in that Doinit method of comp 2 key word : BREAK-POINT .

    If you want set the break point only for your user ID bREAK FOLLOW BY YOUR USER NAME eg: BREAK CHINNAIYAP.

    Regards

    chinnaiya P

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Abhimanyu Lagishetti

      Hi - I went to Basis and they told me that instance profile parameter icm/HTTP/logging_0 did not exist in our systems, but SAP note 1386082 actually fix the issue.

      thanks!

      Jason PV

  • Jun 23, 2010 at 05:05 AM

    Hello,

    just to rule out one very silly/simple possible issue.

    Do you have enough avaliable GUI sessions for the second application to start up a debug session. If you have already the maximum number of GUI sessions running then the breakpoint triggers but can't create a session to display the debugging - so it continues.

    I've hit this a few times when I've got too many sessions running ...

    I doubt this is your problem, but certainly worth ruling out!

    Cheers,

    Chris

    Add comment
    10|10000 characters needed characters exceeded