Skip to Content
author's profile photo Former Member
Former Member

Problem with SQL date type field

Hi, I just moved to SQL Server 2008 and one of my fields is a 'date' type. The data shows as "YYYY_MM_DD". When I add this field to my Crystal Report it does not show up as a date. I am using Crystal Reports XI R2. I tried to use the Date function with it but it gives me an error "Bad Date Format String". Is this a bug in Crystal? What is the best way for me to get my date formatted in mm/dd/yyyy?

Thanks,

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Posted on Jun 21, 2010 at 08:42 PM

    Hi Stacie,

    Are you using the Native 10 client driver or? If so Ms changed the name of the driver and CR doesn't recognize it any more.

    Also, apply Service Pack 6 and then Fix Pack 6.2 and try again.

    If that doesn't resolve it then try a different driver or go into the default report properties and change the default date format. You may want to also try using the Convert Null to Default option.

    Thank you

    Don

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 24, 2010 at 03:08 PM

    Where do I fiind the Fix Pack 6.2? I didn't see it on the Crystal downloads page.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 24, 2010 at 07:30 PM

    I'm have versions XI R2 SP6 installed.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 12, 2010 at 06:58 PM

    Hello Don and Stacie.

    I am facing an interesting variation of this issue and have posted my own question on this topic. If this issue has been resolved or if either of you have any insight to share with me, it would be very much appreciated!

    Thanks so much,

    Matt

    Edited by: Matt Carrithers on Aug 12, 2010 9:05 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 28, 2016 at 09:19 PM

    I found a fix for this problem! I had the same issue and we found that it's the global settings of the computer operating system, not a setting in Crystal or a problem with SQL.

    Go to:

    -Start > Control Panel > Region and Language > Additional Settings

    -Change "No. of digits after decimal" to 0 (zero)

    -Change "digit grouping" to 123456789 (no comma)

    -Click "ok" for both windows and close

    Crystal Reports 2008 v 12.0.0.683

    Product Type: Full

    Sandra

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.